none
Aplicação desenvolvida em framework 2.0 não roda em computador com framework 4.0 instalado RRS feed

  • Pergunta

  • Pessoal estou com problema.

    Ao tentar rodar uma aplicação desenvolvida no framework 2.0 em um computador que só tem o framework 4.0 instalado, aparece mensagem que a plataforma necessária para rodar a aplicação não está instalada.

    Pelo que sei o framework deveria ser retro compatível, alguma ideia do que pode ser? 

    segunda-feira, 29 de julho de 2013 12:19

Todas as Respostas

  • Não, nem sempre. Há coisas que já morreram e a distância do 2 para o 4, é enorme. Talvez se tivesse o 3.0(Absorveria o 2), o 3.5(absorveria o 3) e o 4(absorveria o 3.5), talvez pudesse funcionar(Talvez). Não perca tempo, instale o 2 e comece a trampar ou migre tudo para o 4.0(recomendável).
    • Sugerido como Resposta Márcio S Silva segunda-feira, 29 de julho de 2013 12:51
    segunda-feira, 29 de julho de 2013 12:36
  • O Framework  a cada versão ele tenta ser compatível com suas versões anteriores, mas existe casos que vc use uma funcionalidade da versão 2.0 por exemplo que não tenha no 4.0, pelo fato de ter uma nova funcionalidade que substitui a que está sendo usada na versão anterior, ou pelo fato de configuração tmb, o link abaixo da uma explicação mais ampla.

    http://msdn.microsoft.com/pt-br/library/vstudio/ff602939.aspx

    segunda-feira, 29 de julho de 2013 13:03