none
[Acesso Anônimo] SharePoint 2013 com erro para busca em site público. E agora? RRS feed

  • Pergunta

  • Olá,

    Tenho um site sharepoint 2013 publicado com acesso público.

    Percebi que a busca apenas funciona quando temos usuários logados.

    Como resolver?

    A url de busca é a http://site/_layouts/15/osssearchresults.aspx?u=http://site&k=palavra

    Talvez seja esta página interna em /_layouts/, não sei.

    -

    SocialRESTExceptionProcessingHandler.DoServerExceptionProcessing - SharePoint Server Exception
    [System.InvalidOperationException: A solicitação do token de segurança não pôde ser concluída.     
    em Microsoft.SharePoint.SPSecurityContext.SecurityTokenForServiceContext(Uri contextUri)

    --

    Request does not have SPBasePermissions.UseRemoteAPIs permission. 
    Need to check it when each API is accessed

    --

    Exception occured in scope Microsoft.Office.Server.Search.Query.SearchExecutor.ExecuteQueries.
    Exception=System.InvalidOperationException: A solicitação do token de segurança não pôde ser
    concluída.     em Microsoft.SharePoint.SPSecurityContext.SecurityTokenForServiceContext(Uri contextUri)

    --

    Obrigado


    [Este fórum já foi muito bom, saudades.]
















    • Editado TI DEV terça-feira, 19 de junho de 2018 20:57
    terça-feira, 19 de junho de 2018 18:44

Respostas

  • Olá,

    Não mexi em nada a não ser atualização do sharepoint no servidor.

    Depois disto a busca funcionou para pesquisa anônima.

    Abs


    [Este fórum já foi muito bom, saudades.]


    • Editado TI DEV quinta-feira, 21 de junho de 2018 17:15
    • Marcado como Resposta TI DEV quinta-feira, 21 de junho de 2018 17:15
    quinta-feira, 21 de junho de 2018 17:15