none
IIS Sessao RRS feed

  • Pergunta

  • Olá Pessoal,

     

    Possuo um site publicado no iis que realiza apenas o login e passa parametros via GET para um outro site.

    O que acontece é que quando dois usuários se logam ao mesmo tempo o IIS retorna informações trocadas.

    Por exemplo, 2 usuários "A" e "B" se logam ao mesmo tempo.

     

    O browser de "A" recebe informações referentes ao login de "B".

    Já vasculhei os logs do IIS e Debugado os parametros antes de serem enviados.

    Constatado que o "erro" está no IIS.

     

    Seria alguma configuração no Web.Config?

     

    Poderiam me ajudar?

     

    Seguem algumas informações

     

    IIS 6.0

    Authentication mode="none",  realizada por webService

    .Net 3.5

    Visual Studio 2008

     

    D

    quarta-feira, 15 de outubro de 2008 19:30

Todas as Respostas

  • E qual o fluxo da sua aplicação?

    página aspx (consome webservice)
    web service  (efetua login)
    página aspx (Envia dados get)
    página aspx (Recebe dados)

    É isso?

    Se o web service está retornando os dados trocados então o problema é nele... Acho muito difícil o IIS bugar numa aplicação "simples" assim...

    Abraço!
    sexta-feira, 17 de outubro de 2008 14:17
  • Roberto,

     

    Tenho a explicação detalhada na sessão ASP.NET onde abri uma nova thread,

    inclusive pesso a gentileza do moderador

    que mova estas respostas para o local correto afim de centralizar a solução.

     

    Obrigado pela força!

     

    D

     

    sexta-feira, 17 de outubro de 2008 15:45