none
Abrir formulario e fechar RRS feed

  • Pergunta

  • Boa Noite!!!

    Tenho uma duvida, e segue abaixo.

    Tenho uma aplicação com formulario de login, tela inicial e varias outras, quando entro no sistema abre a tela de login ok, digita a senha e usuario, autentica ok, da um .Hide na tela de login ok, e abre a tela inicial do sistema ok, mas quando abre o formulario de clientes por exemplo efetuo um cadastro, salvo os dados com o codigo abaixo.

    Private Sub btnsalvar_Click(sender As System.Object, e As System.EventArgs) Handles btnsalvar.Click
            Me.Validate()
            Me.TbClientesBindingSource.AddNew()
            Me.TableAdapterManager.UpdateAll(Me.DataSetClientes)

            MsgBox("Cadastro efetuado com Sucesso!!!", MsgBoxStyle.Information)

            Me.txtdata.Focus()

        End Sub

    Só que ai quando fecha o formulario com me.close, e depois se eu quiser cadastrar outro cliente por exemplo, quando abre o formulario de cliente ele abre com os campos de mascara tudo desarrumado e com o codigo errado, como posso resolver isso.

    Desde já agradeço, obrigado.

    quarta-feira, 19 de outubro de 2016 22:01

Respostas

  • Bom dia Pablo_1977

    "...ele abre com os campos de mascara tudo desarrumado e com o codigo errado,"

    Você teria um exemplo de como fica?

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 20 de outubro de 2016 12:21
    Moderador

Todas as Respostas

  • Bom dia Pablo_1977

    "...ele abre com os campos de mascara tudo desarrumado e com o codigo errado,"

    Você teria um exemplo de como fica?

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 20 de outubro de 2016 12:21
    Moderador
  • Bom dia,

    Devido a falta de interação do autor dessa pergunta,

    essa thread está sendo fechada. Caso o problema ainda

    esteja ocorrendo, favor abrir uma nova thread.

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 21 de outubro de 2016 12:44
    Moderador
  • Boa Noite Robson!!!

    Consegui resolver o problema pessoal,

    foi simples mas me custou varias semanas,

    me.close

    me.dispose

    pronto quando fecho o formulario e abro ele de volta o codigo no banco de dados fica normal, antes ele alterava.

    Outra coisa, citei que o codigo retorna errado, eu estava errado, nao e o codigo e o formulario.

    Desde já agradeço a atenção robson.

    quinta-feira, 27 de outubro de 2016 20:44