none
Habilitar a SessionState RRS feed

  • Pergunta

  • Pessoal criei uma WebParts no VS 2010 para o SharePoint 2010, essa webparts contém Session do C#, quando rodo na intranet da erro e pede para habilitar a sessionState. Onde habilita a session?
    Junior Santana
    segunda-feira, 14 de março de 2011 14:21

Respostas

  • Ok,

    O código da tag <pages> está correto.

    Verifique dentro do nó <system.web>, se a tag <httpModules> se parece com esta abaixo:

      <httpModules>
       <add name="FederatedAuthentication" type="Microsoft.SharePoint.IdentityModel.SPFederationAuthenticationModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
       <add name="SessionAuthentication" type="Microsoft.SharePoint.IdentityModel.SPSessionAuthenticationModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
       <add name="SPWindowsClaimsAuthentication" type="Microsoft.SharePoint.IdentityModel.SPWindowsClaimsAuthenticationHttpModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      </httpModules>
    

    Segundo a descrição do erro, falta um módulo do session state nesta tag, me avise se está igual ou se funcionou.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    • Marcado como Resposta Jr_inc terça-feira, 15 de março de 2011 15:19
    terça-feira, 15 de março de 2011 15:00

Todas as Respostas

  • Olá Junior,

    Para habilitar a session state faça o seguinte:

    1 - No PowerShell do SharePoint 2010 digite o seguinte comando:

    Enable-SPSessionStateService –DefaultProvision
    

    2 - No Web.config de cada servidor que você pretenda usar o sessions state, procure a Tag abaixo e  defina seu valor para "true":

    <pages enableSessionState="true">
    

    Espero ter ajudado

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    segunda-feira, 14 de março de 2011 14:38
  • Olá Junior,

    Para habilitar a session state faça o seguinte:

     

    1 - No PowerShell do SharePoint 2010 digite o seguinte comando:

     

    Enable-SPSessionStateService –DefaultProvision
    
    

     

    2 - No Web.config de cada servidor que você pretenda usar o sessions state, procure a Tag abaixo e  defina seu valor para "true":

     

    <pages enableSessionState="true">
    
    

     

    Espero ter ajudado

    Abraços

     


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS

    Onde fica esse PowerShell, no ShareDesigner?
    Junior Santana
    segunda-feira, 14 de março de 2011 17:24
  • No servidor onde está instalado o SharePoint você clica em "Start>All Programs>Microsoft SharePoint 2010 products > SharePoint 2010 Management Shell"

    Se não funcionar o comando, execute este mesmo shell em modo administrador

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    segunda-feira, 14 de março de 2011 17:54
  • No servidor onde está instalado o SharePoint você clica em "Start>All Programs>Microsoft SharePoint 2010 products > SharePoint 2010 Management Shell"

    Se não funcionar o comando, execute este mesmo shell em modo administrador

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS

    Oi Gabriel, não funcionou! deu alguns erros em Inglês em VERMELHO!
    Junior Santana
    terça-feira, 15 de março de 2011 12:08
  • Olá Junior,

    Tem como você reproduzir o erro aqui?

    Tente realizar apenas o passo 2 e veja se já é suficiente para funcionar o que você precisa.

    Já passei por situações, que apenas a alteração no web.config foi suficiente.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    terça-feira, 15 de março de 2011 12:51
  • Olá Junior,

    Tem como você reproduzir o erro aqui?

    Tente realizar apenas o passo 2 e veja se já é suficiente para funcionar o que você precisa.

    Já passei por situações, que apenas a alteração no web.config foi suficiente.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS


    Apenas fazendo o 2 passo não deu certo!

     



    Junior Santana
    terça-feira, 15 de março de 2011 13:51
  • Com relação ao erro no passo 1 o comando está escrito errado. Está escrito tudo junto, porém você deve dar um espaço após o "Enable-SPSessionStateService", porque a parte "–DefaultProvision" é o parametro do cmdlet.

    Com relação ao passo 2, procure a Tag <pages> original do documento, não insira manualmente pois pode haver duplicação. A tag é semelhante a esta:

     

    <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7">
    

     

    E fica dentro da Tag <system.web>

    Tente e avise se funcionou.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    terça-feira, 15 de março de 2011 14:09
  • Com relação ao erro no passo 1 o comando está escrito errado. Está escrito tudo junto, porém você deve dar um espaço após o "Enable-SPSessionStateService", porque a parte "–DefaultProvision" é o parametro do cmdlet.

    Com relação ao passo 2, procure a Tag <pages> original do documento, não insira manualmente pois pode haver duplicação. A tag é semelhante a esta:

     

    <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7">
    
    

     

    E fica dentro da Tag <system.web>

    Tente e avise se funcionou.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS


    Erro

    Session state can only be used when enableSessionState is set to true, either in a configuration file or in the Page directive. Please also make sure that System.Web.SessionStateModule or a custom session state module is included in the <configuration>\<system.web>\<httpModules> section in the application configuration.


    Junior Santana
    terça-feira, 15 de março de 2011 14:20
  • Estou criando a session assim:

     Session["MyData"] = tbDados;

    Ta errado?


    Junior Santana
    terça-feira, 15 de março de 2011 14:27
  • O erro é referente ao passo 2, ou seja, ele não tá encontrando corretamente o arquivo na web.config

    Você inseriu esta TAG (<pages enableSessionState="true">) manualmente ou alterou uma existente?

    Faça uma busca no seu arquivo web.config pela tag "<pages" e verifique se existe mais de uma que possa estar dando conflito.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    terça-feira, 15 de março de 2011 14:37
  • O erro é referente ao passo 2, ou seja, ele não tá encontrando corretamente o arquivo na web.config

    Você inseriu esta TAG (<pages enableSessionState="true">) manualmente ou alterou uma existente?

    Faça uma busca no seu arquivo web.config pela tag "<pages" e verifique se existe mais de uma que possa estar dando conflito.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS


    O Código completo, esta assim:

        <pages enableSessionState="true" enableViewState="true" enableViewStateMac="true" validateRequest="false" pageParserFilterType="Microsoft.SharePoint.ApplicationRuntime.SPPageParserFilter, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" asyncTimeout="7">
          <namespaces>
            <remove namespace="System.Web.UI.WebControls.WebParts" />
          </namespaces>
          <tagMapping>
            <add tagType="System.Web.UI.WebControls.SqlDataSource, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" mappedTagType="Microsoft.SharePoint.WebControls.SPSqlDataSource, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
          </tagMapping>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </controls>
        </pages>


    Junior Santana
    terça-feira, 15 de março de 2011 14:50
  • Ok,

    O código da tag <pages> está correto.

    Verifique dentro do nó <system.web>, se a tag <httpModules> se parece com esta abaixo:

      <httpModules>
       <add name="FederatedAuthentication" type="Microsoft.SharePoint.IdentityModel.SPFederationAuthenticationModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
       <add name="SessionAuthentication" type="Microsoft.SharePoint.IdentityModel.SPSessionAuthenticationModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
       <add name="SPWindowsClaimsAuthentication" type="Microsoft.SharePoint.IdentityModel.SPWindowsClaimsAuthenticationHttpModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      </httpModules>
    

    Segundo a descrição do erro, falta um módulo do session state nesta tag, me avise se está igual ou se funcionou.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    • Marcado como Resposta Jr_inc terça-feira, 15 de março de 2011 15:19
    terça-feira, 15 de março de 2011 15:00
  • Ok,

    O código da tag <pages> está correto.

    Verifique dentro do nó <system.web>, se a tag <httpModules> se parece com esta abaixo:

     

     <httpModules>
    
      <add name="FederatedAuthentication" type="Microsoft.SharePoint.IdentityModel.SPFederationAuthenticationModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
    
      <add name="SessionAuthentication" type="Microsoft.SharePoint.IdentityModel.SPSessionAuthenticationModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
    
      <add name="SPWindowsClaimsAuthentication" type="Microsoft.SharePoint.IdentityModel.SPWindowsClaimsAuthenticationHttpModule, Microsoft.SharePoint.IdentityModel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
    
     </httpModules>
    
    

     

    Segundo a descrição do erro, falta um módulo do session state nesta tag, me avise se está igual ou se funcionou.

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS

    Estava faltando essa TAg do meio. Valeu!!!
    Junior Santana
    terça-feira, 15 de março de 2011 15:20
  • Que bom que resolveu.

     

    Abraços


    Gabriel José A. Nóvoa - MCP/MCDST/MCSA/MCTS/MCITP/MCAS
    terça-feira, 15 de março de 2011 16:56