locked
Fórmulas matriciais no Excel RRS feed

  • Pergunta

  • Oi, pessoal

    Quando vou trabalhar com fórmulas matriciais, o excel não aceita que eu informe uma colunas inteiras como matrizes, como no exemplo:

    =SOMA(SE(B:B="ARROZ";SE(C:C="SUL";D:D;0)))

    Alguém sabe me dizer porque isso acontece???? Ou é algum problema no dispositivo entre a cadeira e o teclado e eu não percebi, rsrs?????

    quarta-feira, 27 de setembro de 2006 19:06

Respostas

  • Oi Raphael,

    a fórmula funciona, mas quando você diz B:B="ARROZ", está dizendo que todas as células da coluna B tenham o valor "ARROZ". 

    sexta-feira, 29 de setembro de 2006 01:47
    Moderador
  • Raphael,

    Desculpe minha intromissão.. mas aqui fucionou normal. Faça o seguinte, ao inves de colocar uma fórmula para toda a planilha, tente fazer com um intervalor menor.

    Fiz o teste e deu certo. Faça também: =SOMA(SE(B1:B5="ARROZ";SE(C1:C5="SUL";D1:D5;0)))  - não esqueça de ao inves de dar ENTER na fórmula, dê SHIFT+CONTROL+ENTER!!!

    Coloquei dados até a linha 4, apenas a linha 5 estava vazia. Alternei entre Arroz e outra coisa e Sul e outra coisa, deu certinho.

    Não sei pq deu errado.

    Espero ter ajudado!

    []'s

    quarta-feira, 4 de outubro de 2006 20:42
  • Raphael,

    realmente acontece isto.. mas esta não sei explicar não.

    Foi mal..

    quarta-feira, 11 de outubro de 2006 19:19

Todas as Respostas

  • Oi Raphael,

    a fórmula funciona, mas quando você diz B:B="ARROZ", está dizendo que todas as células da coluna B tenham o valor "ARROZ". 

    sexta-feira, 29 de setembro de 2006 01:47
    Moderador
  • Oi Luiz.

    Infelizmente comigo não funciona. Mesmo que ele fizesse a verificação disso, a fórmula me daria algum valor, mas quando eu coloco a fórmula matricial pegando uma coluna inteira, ela retorna o erro "#num".

    sábado, 30 de setembro de 2006 19:45
  • Raphael,

    Desculpe minha intromissão.. mas aqui fucionou normal. Faça o seguinte, ao inves de colocar uma fórmula para toda a planilha, tente fazer com um intervalor menor.

    Fiz o teste e deu certo. Faça também: =SOMA(SE(B1:B5="ARROZ";SE(C1:C5="SUL";D1:D5;0)))  - não esqueça de ao inves de dar ENTER na fórmula, dê SHIFT+CONTROL+ENTER!!!

    Coloquei dados até a linha 4, apenas a linha 5 estava vazia. Alternei entre Arroz e outra coisa e Sul e outra coisa, deu certinho.

    Não sei pq deu errado.

    Espero ter ajudado!

    []'s

    quarta-feira, 4 de outubro de 2006 20:42
  • Oi Daniel!

    Quando faço com um intervalo menor a fórmula funciona sem erros... se eu fizer até assim:

    =SOMA(SE(B1:B65535="ARROZ";SE(C1:C65535="SUL";D1:D65535;0)))

    A fórmula funciona sem erro. Eu não entendo pq não funciona quando temos uma coluna inteira, mas já resolvi este problema... Alterei todos os intervalos nomeados que eu tinha numa planilha, que pegavam uma coluna inteira, para pegarem um intervalo da linha 1 até 65535. Agora funciona legal.

    Até mesmo tentando o usar o assistente de soma condicional - que nada faz além de criar uma fórmula matricial de soma - não é possível usar uma coluna inteira como intervalo. Acho que não se pode definir uma coluna como matriz, sei lá...

    segunda-feira, 9 de outubro de 2006 16:53
  • Raphael,

    Na verdade, se houver dados até a ultima linha da planilha (65536), a fórmula não dará erro.

    Acho que o problema é ter muita linha sem dado... não? Tenta completar com dados, dá certo.

    Espero ter ajudado!

     

    segunda-feira, 9 de outubro de 2006 17:05
  • Daniel,

    Não sei se é a versão do office, ou se sou eu o problema... Mas aqui no trabalho, se eu fizer uma fórmula qualquer que pegue um intervalo de 1 até 65536 - p.e.:"$D$1:$D$65536", o excel automaticamente converte o endereço para a referência da coluna - "D:D", e esse tipo de intervalo não é aceito para fórmulas matriciais. Até mesmo no "assistente para soma condicional" (sumif.xla), se eu tento colocar colunas inteiras como lista de valores, ele dá a seguinte mensagem:

    "O intervalo selecionado inclui uma coluna inteira. Selecione apenas as células contendo seus dados."

    Já me achei por aqui, e consegui botar minha fórmula pra rodar, mas continuo curioso em saber porque não se pode usar colunas inteiras numa fórmula matricial.

    quarta-feira, 11 de outubro de 2006 18:58
  • Raphael,

    realmente acontece isto.. mas esta não sei explicar não.

    Foi mal..

    quarta-feira, 11 de outubro de 2006 19:19
  • Daniel,

    Não se "apoquente" quanto a isto.... acho que nem quem programou o excel sabe.

    sexta-feira, 13 de outubro de 2006 14:25