none
Preciso Indicar qual maior faturamento ano e mês RRS feed

  • Pergunta

  • Olá a todos, estou incrementando minha planilha de controle no qual já pedi ajuda aqui, desta vez eu quero que na ultima linha da minha planilha me mostre qual o mês de maior faturamento com o ano correspondente, segue o formato da minha planilha.

    coluna (A) anos 2015 na linha (5), (B) Janeiro......(M) Dezembro na linha (4)

      A            B             C         D             E            F            G          H  .......   M                N                   O

    Anos    Janeiro    Feve.    Março     Abril      Maio     Junho    Julho ...... Dez.     Total/Ano    Crescimento

    2015     R$10      R$20    R$30       R$40      R$50       R$60     R$70 ...... R$120    R$780         ---------

    2016     R$20      R$40     R$60      R$80      R$100                      ......                  R$300            100%      

                                        Ano                 Mês

    Maior Faturamento =   ????            ????????

    Obrigado.

    sábado, 18 de junho de 2016 21:27

Respostas

  • Olá Edson!

    Eu não recorreria ao VBA para solucionar algo assim. 

    Veja uma sugestão:

    As fórmulas da imagem são:

    =ÍNDICE(A2:A3;CORRESP(MÁXIMO(N2:N3);N2:N3;0))

    =ÍNDICE(B1:M1;MÁXIMO(SE(B2:M3=MÁXIMO(B2:M3);COL(B2:M3);0))-1)&"/"&ÍNDICE(A2:A3;MÁXIMO(SE(B2:M3=MÁXIMO(B2:M3);LIN(B2:M3);0))-1)

    Sendo esta última matricial e deve ser inserida com CTRL+SHIFT+ENTER.



    Rafael Kamimura - http://excelmaniacos.com

    domingo, 19 de junho de 2016 02:47

Todas as Respostas

  • Olá Edson!

    Eu não recorreria ao VBA para solucionar algo assim. 

    Veja uma sugestão:

    As fórmulas da imagem são:

    =ÍNDICE(A2:A3;CORRESP(MÁXIMO(N2:N3);N2:N3;0))

    =ÍNDICE(B1:M1;MÁXIMO(SE(B2:M3=MÁXIMO(B2:M3);COL(B2:M3);0))-1)&"/"&ÍNDICE(A2:A3;MÁXIMO(SE(B2:M3=MÁXIMO(B2:M3);LIN(B2:M3);0))-1)

    Sendo esta última matricial e deve ser inserida com CTRL+SHIFT+ENTER.



    Rafael Kamimura - http://excelmaniacos.com

    domingo, 19 de junho de 2016 02:47
  • Obrigado Rafael pela dica de não recorrer ao VBA, é que sou novo no site e outra não tenho habilidades em planilhas, a formula  =ÍNDICE(B1:M1;MÁXIMO(SE(B2:M3=MÁXIMO(B2:M3);COL(B2:M3);0))-1)&"/"&ÍNDICE(A2:A3;MÁXIMO(SE(B2:M3=MÁXIMO(B2:M3);LIN(B2:M3);0))-1)

    ficou legal é isso que eu procurava mas, está me mostrando o ano errado do maior mês de faturamento. Tipo meu maior faturamento foi em Maio de 2016 e a planilha mostra como Maio/2019.

    Será que é porque na minha planilha ja esta pronta até 2024 e tenho celulas vazias? 

    domingo, 19 de junho de 2016 23:40
  • Obrigado pela ajuda já consegui indicar o ano correto.
    • Editado Edsonrb terça-feira, 21 de junho de 2016 12:05
    domingo, 19 de junho de 2016 23:53