locked
PROCV COM FORMULA SE COM DOIS CRITERIOS RRS feed

  • Discussão Geral

  • Pessoal, Boa Tarde.
    Estou montando uma Planilha utilizando Procv com Formula SE. Consegui montar a formula mais queria colocar outro criterio incluiso.

    Tenho uma Planilha desta forma na celula A1 contem uma lista de validação de produtos PTV, V, NF e Conexão.
    Quando escolher algum produto com o procv ele busca o resultado em outra aba. Ate ai perfeito conseguir fazer a formula.
    Segue a Formula para Voces terem uma ideia.

    =SE(E(A1=PTV);Procv(C40;'[Analitico.xls]'!P:U;2,0);SE(E(A1=V);Procv(C40;'[Analitico.xls]'!P:U;3,0);SE(E(A1=NF);Procv(C40;'[Analitico.xls]'!P:U;4,0);SE(E(A1=Conexão);Procv(C40;'[Analitico.xls]'!P:U;5,0)))))

    Agora que vem a duvida amigos preciso da ajuda de voces. Na mesma planilha na celula A2 contem uma lista de validação de periodo: Mensal, 1Q Mes e 2Q Mes.

    Eu queria que quando eu escolhece o produto e o periodo queria que o procv procurasse o resultado do produto pelo perido escolhido. 
    Sei que ira parecer uma tabela dinamica mais a tabela dinamica nao me ajuda.

    Quem poder me ajudar estou agradreçido.
    Obrigado a Todos





         

    quarta-feira, 14 de outubro de 2009 19:52

Todas as Respostas

  • Jonatas,

    Estou considerando que os dados que você deseja retornar estão em uma coluna apenas, e que estão em uma tabela onde o período e produto são colunas adjacentes e interrelacionadas.

    Nomeie a célula (A1?) onde seleciona o produto como "CélulaProduto"
    Nomeie a célula (A2?) onde seleciona o período como "CélulaPeríodo"
    Nomeie o intervalo de produtos como "Produtos"
    Nomeie o intervalo de períodos como "Períodos"
    Nomeie a coluna de dados a serem retornados como "Retorno"

    aplique esta fórmula matricial (Control + Shift + Enter, ao inseri-la), em uma célula vazia:

    =ÍNDICE(Retorno;CORRESP(CélulaPeríodo&CélulaProduto;Períodos&Produtos;0))

    []
    ALeXceL
    BeAgÁ
    sábado, 21 de novembro de 2009 23:17