locked
Função PROCV Repete Resultado (Microsoft Office) RRS feed

  • Pergunta

  • Boa tarde!

    Srs.,

    Estou tentando criar um ranking de vendas para os clientes da empresa que trabalho. O problema é o seguinte: alguns clientes venderam exatamente o mesmo valor! :) Quando vou usar a PROCV ela me retorna resultados repetidos. E isso, obviamente não deve acontecer em um ranking. Alguém pode me ajudar? Segue o modelo da planilha abaixo:

    VENDAS CLIENTE RANKING MAIORES VENDAS CLIENTE
     R$  420.000,00 PHILIPS  1.º   =MAIOR($A$2:$A$11;1)  =PROCV(E2;A:B;2;0)
     R$  190.000,00 SONY  2.º   R$                     310.000,00 SHARP
     R$  150.000,00 PANASONIC  3.º   R$                     310.000,00 SHARP
     R$  150.000,00 LG  4.º   R$                     270.000,00 CCE
     R$  270.000,00 CCE  5.º   R$                     250.000,00 SEMP TOSHIBA
     R$  250.000,00 SEMP TOSHIBA  6.º   R$                     210.000,00 PHILCO
     R$  310.000,00 SHARP  7.º   R$                     190.000,00 SONY
     R$  210.000,00 PHILCO  8.º   R$                     150.000,00 PANASONIC
     R$  140.000,00 JVC  9.º   R$                     150.000,00 PANASONIC
     R$  310.000,00 MITSUBISHI  10.º   R$                     140.000,00 JVC

     

    Desde já agradeço a habitual atenção,

    Logístico

    • Movido AndreAlvesLima sexta-feira, 28 de janeiro de 2011 18:15 (De:Grupos de Usuários)
    sexta-feira, 28 de janeiro de 2011 15:56

Todas as Respostas

  • Prezado(a),

    Estou migrando seu post para o fórum de Excel.

    Por favor, das próximas vezes que tiver alguma dúvida relacionada a esse assunto, poste por lá.

    Obrigado.


    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima
    sexta-feira, 28 de janeiro de 2011 18:14
  • Melhor usar a função ORDEM( valor ; lista de valores) 


    Essa função vai dar o ranking do valor da venda na lista de valores de venda

     

    Depois disso, vc pode pegar os clientes e listá-los em ordem.

     


    João Eurico Consultor Manguetown - Brazil
    sexta-feira, 28 de janeiro de 2011 19:23
  • Aqui tem uma planilha genérica para servir de exemplo e inspiração para você.

     

    Como classificar tabela sem usar macros

     


    João Eurico Consultor Manguetown - Brazil
    sexta-feira, 28 de janeiro de 2011 19:24