none
IronPython Erro update Pip versão 9 para versão 18.1 RRS feed

  • Discussão Geral

  • Bom dia.

    Estou tendo problemas para atualizar o PIP da versão 9 para a versão 18.1, fica dando a mensagem a baixo e não funciona:

    ----- Instalando 'pip' -----
    Collecting pip==18.1
    Exception:
    Traceback (most recent call last):
      File "C:\Users\Link\AppData\Roaming\Python\IronPython27\site-packages\pip\basecommand.py", line 215, in main
        status = self.run(options, args)
      File "C:\Users\Link\AppData\Roaming\Python\IronPython27\site-packages\pip\commands\install.py", line 324, in run
        requirement_set.prepare_files(finder)
      File "C:\Users\Link\AppData\Roaming\Python\IronPython27\site-packages\pip\req\req_set.py", line 376, in prepare_files
        discovered_reqs.extend(self._prepare_file(
      File "C:\Program Files\IronPython 2.7\Lib\contextlib.py", line 35, in __exit__
        self.gen.throw(type, value, traceback)
      File "C:\Users\Link\AppData\Roaming\Python\IronPython27\site-packages\pip\utils\logging.py", line 36, in indent_log
        yield
    TypeError: Cannot set an encoding with a unicode input, set ['transport_encoding']
    You are using pip version 9.0.3, however version 18.1 is available.
    You should consider upgrading via the 'python -m pip install --upgrade pip' command.
    ----- 'pip' instalado com êxito -----

    Alguém saberia como resolver tal problema?


    obs.: tenho o python 3 com o pip na versão 18.1

    segunda-feira, 10 de dezembro de 2018 08:52