locked
Solução de Procv aninhado RRS feed

  • Pergunta

  •  

    Colegas, bom dia!!!

     

    Tenho um controle no meu trabalho que é feito através de planilha de Excel compartilhada, e para não ocorrer perda de dados, cada um preenche seu controle em uma guia com seu respectivo nome. Necessito de uma guia que contenha todos os processos, para que o gestor possa acompanhar a atividade como um todo, então estabeleci o seguinte padrão:

     

    Obs.: Tentarei explicar exatamente o que quero e o que tentei fazer!

     

    Um colaborador que está designado a receber o processo via e-mail, entra na guia geral e insere na 1º coluna o código do processo, na 2º o tipo de produto e na 3º a data que foi iniciado. Após este procedimento ele repassa via e-mail para um dos 10 colaboradores, distribuindo assim as atividades.

     

    O colaborador que recebe a proposta digita  em sua guia individual, na 1º coluna, o código do processo, e por “PROCV” na guia geral os campos “tipo do produto” e “data inicial” aparecem. Nas colunas seguinte, insere diversas informações conforme acompanha o processo.

     

    Acontece que necessito que os dados que os 10 colaboradores preenchem referente aos processos, sejam puxados para a guia geral e pensei o seguinte:

     

    Uso a função “SE” juntamente com  “PROCV” para procurar através do código inserido inicialmente, nas guias 1, 2, 3, 4, 5, 6, 7, 8 (máximo de funções “se” são 8 e como tem 10 colaboradores, crio uma segunda coluna usando novamente “SE” e “PROCV”para as guias restantes), o resultado aparece em uma 3º célula e as 2 que contem as fórmulas ficam ocultas. Ótimo, assim funcionou, porém são 30 campos que os colaboradores preenchem na planilha individual e a guia geral ficou gigantesca e MUUUUITTTTOO pesada, tornando inviável.

     

    Na segunda opção, a qual tenho dúvidas como proceder, pensei o seguinte:

     

     

    Quando o colaborador que repassa a atividade escolher para quem envia o processo, informa pra quem foi na 4º coluna.

     

    Utilizo uma única e leve fórmula “PROCV” e para definir a matriz na guia a ser procurada, uso a informação inserida pelo colaborador que repassa a atividade para identificar a guia. Ex.:

     

    Na célula “A4” da guia “geral” Informo o nome da pessoa, que é o mesmo que esta em uma das guias individuais.

     

    O “PROCV” normal ficaria assim :  =PROCV($A1;Plan2!$A$1EmbarrassedAJ$300;10;0)

     

    Da forma que pensei o “PROCV” fica assim =PROCV($A1;A4&$A$1EmbarrassedAJ$300;10;0)

    Ou  =PROCV($A1;texto(A4;0)&$A$1EmbarrassedAJ$300;10;0).

    Tentei assim também:

    =PROCV(A$1;"'"&TEXTO(A4;0)&"'"&"!"&$A$1EmbarrassedAJ$300;10;0)

     

    =PROCV(A$1TEXTO(A4;0)&"!"&$A$1EmbarrassedAJ$300;10;0)

     

    =PROCV(A$1;"'"&valor(A4)&"'"&"!"&$A$1EmbarrassedAJ$300;10;0)

     

    =PROCV(A$1; valor(A4)&"!"&$A$1EmbarrassedAJ$300;10;0)

     

     

     

    Ou seja, dependendo do que o colaborador informar na célula “A4” da guia geral, que será variável, e assim o “PROCV” vai procurar em guias diferentes, ou melhor, na guia certa de acordo com a variável informada na “A4”.

     

    Alguém tem idéia de como ou se tem como fazer isso?

    quarta-feira, 12 de março de 2008 15:02

Todas as Respostas

  • Nikolas,

    Tente desta forma: =PROCV($A$1;INDIRETO(A4&"!$A$1EmbarrassedAJ$300");10;FALSO)

    O objetivo da função INDIRETO é transformar uma cadeia de texto (ex. "Plan2!$A$1EmbarrassedBJ$300") ser reconhecida como um endereço de referência.

     

    Outra sintaxe é possível, combinando as funções INDIRETO e ENDEREÇO da seguinte forma:

    =PROCV($A$1;INDIRETO(ENDEREÇO(1;1;1;1;A4)&":"&ENDEREÇO(300;62));2;FALSO)

     

    E ainda me ocorre uma terceira,combinando as duas funções acima com a função DESLOC

    =PROCV($A$1;DESLOC(INDIRETO(ENDEREÇO(1;1;;;A4));0;0;300;62);2;FALSO)

     

    Veja qual delas se ajusta melhor às tuas necessidades.

     

    PS: Algumas vezes aaprecem emoticons no lugar de dois pontos ":', portanto não estranhe esta representação

    [ ]s

    quarta-feira, 12 de março de 2008 16:17
  • Pessoal

     

    Raciocinando na mesma linha vcs poderiam me ajudar com o meu problema?

     

    Ocorre o seguinte no meu caso to tentando colocar na formula PROCV total de linhas finais q ele deve criar a matriz, usando a formula indireto.

     

    Ex.:

     

     

    =INDIRETO(PROCV(D4;$A:"&CONT.VALORES(Cadastro!A10)&";2;0"))

     

    Pois o valores final da matriz eu pego conforme o numero de linhas cadastradas.

     

    Tem outro jeito de interpretar isso sem ser com o INDIRETO

    sexta-feira, 15 de agosto de 2008 18:28