none
WebUserControl RRS feed

  • Pergunta

  • Em um WebForm eu inseri um WebUserControl e esporadicamente aparece um Warning com a seguinte mensagem:

    Element 'WebUserControlSIAmenu' is not a known element. This can occur if there is a compilation error in the Web site, or the web.config file is missing. C:\Users\Bra\documents\visual studio 2010\Projects\B\B_SIA\CADASTRO.aspx 139 26 B_SIA

    Então eu removo e insero novamente, após algum tempo volta a apresentação da mensagem. O trecho do codigo HTML abaixo, se alguém tiver algo a recomendar eu agradeço antecipadamente:

    <body>
        <form id="form1" runat="server">
        <center>
        <div>
            <asp:ToolkitScriptManager ID="ToolkitScriptManager1" runat="server">
            </asp:ToolkitScriptManager>
            <asp:Panel ID="Panel1" runat="server" Width="950px">
                <asp:UpdatePanel ID="UpdatePanel3" runat="server">
                    <ContentTemplate>
                        <uc1:WebUserControlSIADSmenu ID="WebUserControlSIAmenu2" runat="server" />
                    </ContentTemplate>
                </asp:UpdatePanel>
              </asp:Panel>

    segunda-feira, 4 de junho de 2012 16:37

Respostas

  • Wilson, postei uma solução lá na outra thread.

    o/


    Rafael Santos

    Observações:
    1. Selecione a opção "Habilitar o Live Alerts por Padrão" nas suas configurações para que possa acompanhar em tempo real as atividades relacionadas a sua Thread;
    2. Não abandone sua Thread. Ao perguntar, fique atento às respostas; ao encontrar uma solução, compartilhe;
    3. As pessoas que dedicam seu tempo na busca por soluções para você não ganham nada em troca. Valorize-as e em forma de agradecimento pontue as respostas corretas.

    "Quem disse que não escrevo poesias? A diferença é que as minhas começam com using System;"

    • Marcado como Resposta Wilson Boris sexta-feira, 17 de agosto de 2012 17:31
    sexta-feira, 17 de agosto de 2012 15:40

Todas as Respostas

  • O erro está dando na compilação. Você tem certeza que a compilação está sendo realizada com sucesso em outras partes do seu projeto?

    Por exemplo. Se eu mando compilar meu projeto e imediatamente, antes mesmo de acabar, abro meu site, eu tenho um erro no Global.asax. Se tiver algum outro erro, a mesma coisa.

    Então, pode ser que tenha alguma área fora do seu UserControl que esteja com problema na compilação.


    Rafael Santos

    Observações:
    1. Selecione a opção "Habilitar o Live Alerts por Padrão" nas suas configurações para que possa acompanhar em tempo real as atividades relacionadas a sua Thread;
    2. Não abandone sua Thread. Ao perguntar, fique atento às respostas; ao encontrar uma solução, compartilhe;
    3. As pessoas que dedicam seu tempo na busca por soluções para você não ganham nada em troca. Valorize-as e em forma de agradecimento pontue as respostas corretas.

    "Quem disse que não escrevo poesias? A diferença é que as minhas começam com using System;"


    • Editado Rafa Santos quinta-feira, 16 de agosto de 2012 14:44
    quinta-feira, 16 de agosto de 2012 14:42
  • Olá Eder e Rafa!

    muito obrigado pelo retorno Eder e Rafa. Desculpem-me, pois o Rafa tem razão quanto a minha falha eu postei este problema em 04 de junho e como não obtive retornos acabei mudando a estrutura da página, conforme abaixo, assim  deixou de apresentar o problema. Por outro lado levou-me ao entrave com o comando menu da aba navigation. Eu postei este problema em 31 de julho com o título Navigation Menu no forum ASP.NET.

    <body>
        <form id="form2" runat="server">
           <asp:ToolkitScriptManager ID="ToolkitScriptManager1" runat="server">
           </asp:ToolkitScriptManager>
                <uc1:MENU ID="MENU1" runat="server" />

    Pesso Sugestões para encaminhamento deste Post.

    Novamente perdõem-me e concordo absolutamente com as observações do Rafa. Valeu Amigo!

    sexta-feira, 17 de agosto de 2012 01:06
  • Olá Eder e Rafa!

    muito obrigado pelo retorno Eder e Rafa. Desculpem-me, pois o Rafa tem razão quanto a minha falha eu postei este problema em 04 de junho e como não obtive retornos acabei mudando a estrutura da página, conforme abaixo, assim  deixou de apresentar o problema. Por outro lado levou-me ao entrave com o comando menu da aba navigation. Eu postei este problema em 31 de julho com o título Navigation Menu no forum ASP.NET.

    <body>
        <form id="form2" runat="server">
           <asp:ToolkitScriptManager ID="ToolkitScriptManager1" runat="server">
           </asp:ToolkitScriptManager>
                <uc1:MENU ID="MENU1" runat="server" />

    Pesso Sugestões para encaminhamento deste Post.

    Novamente perdõem-me e concordo absolutamente com as observações do Rafa. Valeu Amigo!

    Wilson, vc pode colocar o link do tópico novamente aqui pra eu tentar te ajudar? Não garanto uma resposta hj, mas amanhã com certeza. Até pra dizer q eu não sei. XD

    Rafael Santos

    Observações:
    1. Selecione a opção "Habilitar o Live Alerts por Padrão" nas suas configurações para que possa acompanhar em tempo real as atividades relacionadas a sua Thread;
    2. Não abandone sua Thread. Ao perguntar, fique atento às respostas; ao encontrar uma solução, compartilhe;
    3. As pessoas que dedicam seu tempo na busca por soluções para você não ganham nada em troca. Valorize-as e em forma de agradecimento pontue as respostas corretas.

    "Quem disse que não escrevo poesias? A diferença é que as minhas começam com using System;"

    sexta-feira, 17 de agosto de 2012 01:12
  • sexta-feira, 17 de agosto de 2012 01:19
  • Wilson, postei uma solução lá na outra thread.

    o/


    Rafael Santos

    Observações:
    1. Selecione a opção "Habilitar o Live Alerts por Padrão" nas suas configurações para que possa acompanhar em tempo real as atividades relacionadas a sua Thread;
    2. Não abandone sua Thread. Ao perguntar, fique atento às respostas; ao encontrar uma solução, compartilhe;
    3. As pessoas que dedicam seu tempo na busca por soluções para você não ganham nada em troca. Valorize-as e em forma de agradecimento pontue as respostas corretas.

    "Quem disse que não escrevo poesias? A diferença é que as minhas começam com using System;"

    • Marcado como Resposta Wilson Boris sexta-feira, 17 de agosto de 2012 17:31
    sexta-feira, 17 de agosto de 2012 15:40