none
conexão com o servidor RRS feed

  • Pergunta

  • Boa tarde.

    Tenho uma aplicação Windows Form que só funciona em máquinas que tenham uma cópia do Banco de dados, mas quando tento conectar com o servidor não funciona e dá o seguinte erro: Falha no logon do usuário 'PEMADMIN'.

    Segue cópia do AppConfig.  Só funciona com a conexão que está comentada que está na minha máquina

        <!--<add
    name="DELTA.Properties.Settings.conexao" connectionString="Data
    Source=DEV-HOME\SQLEXPRESS;Initial Catalog=SGASERVER;Integrated
    Security=True"
       
    providerName="System.Data.SqlClient" />
    -->

        <add name="DELTA.Properties.Settings.conexao" connectionString="Data
    Source=DEMO-SERVER\SQLEXPRESS;Initial Catalog=SGASERVER;User
    ID=PEMADMIN;Password=***********
    "

          providerName="System.Data.SqlClient" />


     
    quinta-feira, 16 de fevereiro de 2012 17:10

Respostas

  • Olá Cavo,

    Na sua connection string vc esta utilizando a sequência "IntegratedSecurity=true" esta clausula indica que vc fará a conexão com as credenciais do usuário que estiver logado em sua máquina. Provavel que vc esteja logado com o usuário PEMADMIN, mas as permissões para este usuário no banco de dados não estejam habilitadas.

    Neste caso vc deve dar permissões para este usuário no seu banco de dados.

    Não sou muito fã desse tipo de autenticação, prefiro que vc passe a senha e o usuário pela connection string assim como vc estava fazendo no exemplo de conexão que funciona corretamente.

    []s!


    Fernando Henrique Inocêncio Borba Ferreira
    while(alive){ this.WriteCode(); }
    Blog: http://ferhenriquef.com/
    Twitter: @ferhenrique

    quarta-feira, 22 de fevereiro de 2012 21:32
    Moderador

Todas as Respostas

  • Olá,

    Você já tentou utilizar o SQL Server Management Studio para tentar se conectar no banco utilizando esse usuário e senha? Se sim e estiver funcionando, o que pode estar acontecendo é que o SQL Server não está configurado para receber conexões remotas (que é a configuração default)... Você chegou a habilitar essa opção?

    http://www.linglom.com/2009/03/28/enable-remote-connection-on-sql-server-2008-express/


    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima

    quarta-feira, 22 de fevereiro de 2012 20:05
    Moderador
  • Prezado(a),
    Estou migrando seu post para o fórum de Acesso a Dados.
    Por favor, das próximas vezes que tiver alguma dúvida relacionada a esse assunto, poste por lá.
    Obrigado.

    André Alves de Lima
    Microsoft MVP - Client App Dev
    Visite o meu site: http://www.andrealveslima.com.br
    Me siga no Twitter: @andrealveslima

    quarta-feira, 22 de fevereiro de 2012 20:06
    Moderador
  • AMIGO TENTA ASSIM.

    SÓ MODIFICA OS PARA O SEU SERVIDOR QUE DEVE FUNCIONAR.

    <connectionStrings>
    <add name="CONEXAOSQL" connectionString="Data Source=10.12.86.110;Initial Catalog=BASE DE DADOS;User ID=USUARIO;Password=SENHA"/>
    </connectionStrings>


    Caso a resposta tenha ajudado favor marcar como respondida.

    quarta-feira, 22 de fevereiro de 2012 20:40
  • Olá Cavo,

    Na sua connection string vc esta utilizando a sequência "IntegratedSecurity=true" esta clausula indica que vc fará a conexão com as credenciais do usuário que estiver logado em sua máquina. Provavel que vc esteja logado com o usuário PEMADMIN, mas as permissões para este usuário no banco de dados não estejam habilitadas.

    Neste caso vc deve dar permissões para este usuário no seu banco de dados.

    Não sou muito fã desse tipo de autenticação, prefiro que vc passe a senha e o usuário pela connection string assim como vc estava fazendo no exemplo de conexão que funciona corretamente.

    []s!


    Fernando Henrique Inocêncio Borba Ferreira
    while(alive){ this.WriteCode(); }
    Blog: http://ferhenriquef.com/
    Twitter: @ferhenrique

    quarta-feira, 22 de fevereiro de 2012 21:32
    Moderador
  • AMIGO TENTA ASSIM.

    SÓ MODIFICA OS PARA O SEU SERVIDOR QUE DEVE FUNCIONAR.

    <connectionStrings>
    <add name="CONEXAOSQL" connectionString="Data Source=10.12.86.110;Initial Catalog=BASE DE DADOS;User ID=USUARIO;Password=SENHA"/>
    </connectionStrings>


    Caso a resposta tenha ajudado favor marcar como respondida.

    Lembrando que vc deve dar permissão de acesso ao seu usuario criado no bando de dados.


    Caso a resposta tenha ajudado favor marcar como respondida.

    quinta-feira, 23 de fevereiro de 2012 11:40
  • Bom dia!

    Desculpe-me pela falta de resposta, pois eu não estava achando o meu post eu havia colocado no Window Forms App.

    E a minha conexão válida para o servidor é a que não está comentada, e quanto ao restante das sugestões vou testar segunda-feira e por enquanto

    obrigado pela atenção.

    sábado, 25 de fevereiro de 2012 11:44