none
SQLite problema na acentuação. RRS feed

  • Pergunta

  • Olá Pessoal

    Estou com problemas na acentuação no sqlite.

    Como posso cadastra com acento e recuperar sem problema.

    Estou trabalhando com C# Windows FORM.

    sexta-feira, 13 de novembro de 2015 20:21

Respostas

  • Olá!

    Bom, pelo que você mostrou do código, acredito que o problema não seja o momento da inclusão não.

    Tente criar o seu banco com o encoding UTF-8

    Eu uso o SQLite Expert Personal, é uma boa ferramenta também, e inclusive te dá opções de encoding no momento da criação do banco.

    Espero que isso te ajude, mas se não resolver, avise que vamos verificar! :)

    • Marcado como Resposta Marcos SJ segunda-feira, 16 de novembro de 2015 12:59
    domingo, 15 de novembro de 2015 16:39

Todas as Respostas

  • Olá!

    No momento em que você criou o banco, você definiu o encoding dele?

    Talvez possa ser por isso que está tendo alguns problemas.

    Se não for o caso, fale um pouco mais sobre o problema, talvez eu consiga te ajudar! :)

    • Sugerido como Resposta Danilo Telles sexta-feira, 13 de novembro de 2015 22:20
    sexta-feira, 13 de novembro de 2015 21:06
  • Bom dia Ana.

    Obrigado pela atenção.

    Sou novo com essa base de dados. Não lembro como criei.

    Baixei o sqliteadmin e vou montar outra base e fazer os teste.

    domingo, 15 de novembro de 2015 12:34
  • Segue como esta sendo incluído o registro.

                            

         Código de incluisão:

               string s = "João Bosco";
                string strcon = @"Data Source=C:\Temp\base.s3db";
                SQLiteConnection conn = new SQLiteConnection(strcon);
                conn.Open();
                string sqll = "INSERT INTO cli(nome) VALUES ('João Bosco')";
                SQLiteCommand sqlcomm = new SQLiteCommand(sqll, conn);
                sqlcomm.Parameters.Add(new SQLiteParameter("@nome", s));
                sqlcomm.ExecuteNonQuery();

    domingo, 15 de novembro de 2015 14:46
  • Olá!

    Bom, pelo que você mostrou do código, acredito que o problema não seja o momento da inclusão não.

    Tente criar o seu banco com o encoding UTF-8

    Eu uso o SQLite Expert Personal, é uma boa ferramenta também, e inclusive te dá opções de encoding no momento da criação do banco.

    Espero que isso te ajude, mas se não resolver, avise que vamos verificar! :)

    • Marcado como Resposta Marcos SJ segunda-feira, 16 de novembro de 2015 12:59
    domingo, 15 de novembro de 2015 16:39