none
Banco de Dados EXCEL - O maior título somando as ocorrências RRS feed

  • Pergunta

  • Olá, tenho a seguinte situação:

    Ocorrências Título
    2 AA
    4 BB
    14 CC
    6 AA
    2 CC
    14 AA
    6 AA
    10 BB
    8 CC
    8 DD
    0 BB
    8 DD
    14 AA


    Gostaria de saber se existe uma maneira automática para que o Excel me informe quais são os títulos correspondentes aos critérios "=maior()" e "=SOMA".

    Ou seja, qual dos títulos corresponde ao maior valor somado em uma só fórmula ?

    Por exemplo, quero saber, automaticamente, qual o titulo com maior ocorrências somadas, bem como o segundo, o terceiro, etc.

    Agradeço desde já a ajuda!

    terça-feira, 5 de janeiro de 2016 18:16

Todas as Respostas

  • Olá

    Acredito que a sua idéia seja rankear as informações.

    Abaixo segue um link que creio irá atender sua necessidade

    http://blog.luz.vc/excel/usando-funcoes-maior-e-menor-para-fazer-ranking-excel/

    Att

    Ana Paula

    terça-feira, 5 de janeiro de 2016 18:39
  • Obrigado Ana Paula, mas não é isso.

    pode ser rankeado, mas somando títulos iguais, por exemplo, fazendo de cabeça, deveria me retornar o rank abaixo:

    mas, preciso isso em apenas uma função do excel.

    Obrigado!


    1°   42      AA
    2°   24      CC
    3°   16      DD
    4°   10      BB
    terça-feira, 5 de janeiro de 2016 19:01
  • Marcelo

    Outra alternativa seria utilizar o Power Query disponível para as versões do Office 2013 ou 2010 Plus e realizar o agrupamento prévio da planilha e depois rankear.

    Creio que é uma alternativa

    https://support.office.com/en-ca/article/Group-rows-in-a-table-Power-Query-e1b9e916-6fcc-40bf-a6e8-ef928240adf1?ui=en-US&rs=en-CA&ad=CA

    Att

    terça-feira, 5 de janeiro de 2016 19:18
  • Meu Office é 2010, ainda não possui este recurso :(

    Obrigado!!;)

    quinta-feira, 7 de janeiro de 2016 11:50
  • Não me ajudou!
    quinta-feira, 14 de janeiro de 2016 16:58
  • Para fazer isso você pode usar o calculo de =SOMASE(), assim você vai somar apenas os item que tem na coluna de titulo as letras "AA" por exemplo

    veja mais exemplos nesse link:

    http://www.aprenderexcel.com.br/2013/tutoriais/como-fazer-soma-condicional-no-excel

    Para fazer o ranking você pode usar o =SE mesmo e analisar os casos um a um ou usar o =MAIOR() para analisar quem ficara acima de quem


    If the answer was helpful vote

    • Sugerido como Resposta Jean LLopes quinta-feira, 14 de janeiro de 2016 17:12
    • Não Sugerido como Resposta Marcelo_Rosa12 quarta-feira, 20 de janeiro de 2016 13:21
    • Sugerido como Resposta Jean LLopes quarta-feira, 20 de janeiro de 2016 13:57
    • Não Sugerido como Resposta Marcelo_Rosa12 quarta-feira, 20 de janeiro de 2016 16:40
    quinta-feira, 14 de janeiro de 2016 17:12
  • acho que você não entendeu o questionamento, agradeço sua ajuda.

    Mas se a solução fosse tão simples assim eu não consultaria o tutorial aqui.

    Seria algo parecido com isso:

    =IF(ISNA(VLOOKUP(LARGE(A2:A14;1);A2:B14;2;0));"";VLOOKUP(LARGE(A2:A14;1);A2:B14;2;0))

    mas a fórmula acima não ranqueia de acordo com a somatória.

    Obrigado!!



    quarta-feira, 20 de janeiro de 2016 13:16