none
Contar quantidade de resultados por data sem contabilizar as repetições. RRS feed

  • Pergunta

  • Prezados bom dia,

    Preciso contar o número de resultados por número de registros sem que seja contabilizados as repetições.

    Tipo por cada número de registro apenas contabilizar 1 número de registro por data independente se há repetições.

    Gostaria de saber se seria possível fazer esta tarefa por fórmula excel ou macro?

    Para facilitar anexo o link com uma planilha de exemplo.

    https://www.sendspace.com/file/2ipw23

    Na planilha original tenho uns 10 mil registros.

    Desde já agradeço a ajuda.

    Ex:

    Plan1

    N_Registro         Data                     Comentário               Resultados

    10001           05-NOV-2014             Tipo C                    Sem Resposta

    10001           05-NOV-2014             Não Classificado      Efetivo

    10001           05-NOV-2014             Não Classificado      Fechado

    10001           06-NOV-2014             Tipo A                    Efetivo

    10001           06-NOV-2014             Tipo A                    Sem Resposta

    Plan2

    Ano 2014

    Mês 11

    Dia    Resultado

    1

    2

    3

    4

    5          1

    6          1


    • Editado fabiosantos11 quarta-feira, 3 de dezembro de 2014 12:22
    terça-feira, 2 de dezembro de 2014 13:26

Respostas

  • Em Plan2,

    Na célula A4, escreva a fórmula a seguir, pressione Ctrl+Shift+Enter:

    =SEERRO(ÍNDICE(Plan1!$B$2:$B$25;CORRESP(0;CONT.SE(Plan1!$B$2:$B$25;"<"&Plan1!$B$2:$B$25)-SOMA(CONT.SE(Plan1!$B$2:$B$25;"="&A$3:A3));0));"")

    Em seguida, copie-a até a célula A34.

    ---

    Na célula B4, escreva a fórmula a seguir, pressione Ctrl+Shift+Enter:

    =SOMA(SE(FREQÜÊNCIA(SE(Plan1!$B$2:$B$25=A4;Plan1!$A$2:$A$25);SE(Plan1!$B$2:$B$25=A4;Plan1!$A$2:$A$25));1))

    Em seguida, copie-a até a célula B34.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta fabiosantos11 sábado, 6 de dezembro de 2014 16:48
    sexta-feira, 5 de dezembro de 2014 21:50
    Moderador

Todas as Respostas

  • Experimente utilizar a fórmula a seguir:

    =SOMA(SE(FREQÜÊNCIA(CORRESP(A2:A25&B2:B25;A2:A25&B2:B25;0);LIN(A2:A25)-LIN(A2)+1);1))


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    quarta-feira, 3 de dezembro de 2014 21:06
    Moderador
  • Felipe boa noite, muito obrigado! Desculpe testei a formula mas não está fazendo a contagem conforme minha necessidade. Necessito que os dados da plan 1 seja contabilizados na  plan2 desta forma:

    Ex:

    Dia  Mês  Resultado Quantidade

    1      nov        1

    2      nov        1

    e assim sucessivamente.

    Quando testei a formula ela estava contando o total geral de cada número mas preciso saber quantos registros tem cada número por dia sem contar os repetidos.

    Muito obrigado!

    Abraços.


    • Editado fabiosantos11 quinta-feira, 4 de dezembro de 2014 13:28
    quarta-feira, 3 de dezembro de 2014 22:45
  • Em Plan2,

    Na célula A4, escreva a fórmula a seguir, pressione Ctrl+Shift+Enter:

    =SEERRO(ÍNDICE(Plan1!$B$2:$B$25;CORRESP(0;CONT.SE(Plan1!$B$2:$B$25;"<"&Plan1!$B$2:$B$25)-SOMA(CONT.SE(Plan1!$B$2:$B$25;"="&A$3:A3));0));"")

    Em seguida, copie-a até a célula A34.

    ---

    Na célula B4, escreva a fórmula a seguir, pressione Ctrl+Shift+Enter:

    =SOMA(SE(FREQÜÊNCIA(SE(Plan1!$B$2:$B$25=A4;Plan1!$A$2:$A$25);SE(Plan1!$B$2:$B$25=A4;Plan1!$A$2:$A$25));1))

    Em seguida, copie-a até a célula B34.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta fabiosantos11 sábado, 6 de dezembro de 2014 16:48
    sexta-feira, 5 de dezembro de 2014 21:50
    Moderador
  • Felipe boa tarde.

    Muito obrigado!

    Funcionou perfeitamente.

    Você não imagina como foi útil sua ajuda.

    Você e mestre no assunto hein..rs

    Abraços.

    sábado, 6 de dezembro de 2014 16:48
  • Felipe bom dia. Desculpe incomodar. Preciso empregar esta tarefa em outra planilha com 4000 registros e se possível poderia por gentileza explicar o funcionamento da formula. Desde já agradeço Abraços.
    • Editado fabiosantos11 segunda-feira, 8 de dezembro de 2014 08:59
    segunda-feira, 8 de dezembro de 2014 08:58
  • Você quer saber do funcionamento da formula por curiosidade ou não sabe adapta-la para a planilha de 4000 registros? Se for o caso, adapte B$2:$B$25 para B$2:$B$4001

    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    segunda-feira, 8 de dezembro de 2014 12:59
    Moderador
  • Felipe boa noite. Muito obrigado pela resposta. Quero saber o funcionamento por curiosidade e também para aprender pois esse é uns dos objetivos de participar deste fórum. Abraços
    segunda-feira, 8 de dezembro de 2014 23:32
  • Olá Felipe,

    Estava estudando a formula que você criou e consegui entender algumas coisas.

    Poderia verificar se meus comentários estão de acordo.

    Essa parte puxa a data =SEERRO(ÍNDICE(Plan1!$B$2:$B$25;CORRESP

    Essa compara (0;CONT.SE(Plan1!$B$2:$B$25;"<"&Plan1!$B$2:$B$25)-SOMA(CONT.SE(Plan1!$B$2:$B$25;

    Agora essa parte final ;"="&A$3:A3));0));"")  eu não entendi.

    Gostaria que se possível você me explicasse.

    Abraços.

    quinta-feira, 11 de dezembro de 2014 13:10