none
Server Error in '/' Application. RRS feed

  • Pergunta

  • Após fazer o Publish e tranferência ftp ao abrir a página aparece a mensagem abaixo, alguém sugere algo?

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Could not load type 'APBD.index'.

    Source Error:
    Line 1:  <%@ Page Language="vb" AutoEventWireup="false" CodeBehind="index.aspx.vb" Inherits="APBD.index" %>
    Line 2:  
    Line 3:  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    Source File: /index.aspx   Line: 1


    Version Information: Microsoft .ASP.NET Version:4.0.30319.272
     
    sábado, 27 de outubro de 2012 17:30

Respostas

  • Olá Wilson.

    A estrutura correta, considerando que WWW é pasta configurada no seu servidor web como a pasta raiz da sua aplição, seria:

    estrutura de pastas

    Observe que a pasta WWW não entra na estrutura, pois ela é a pasta raiz do seu site. 

    Abraços.


    Washington Luíz | MCP, MCTS
    O Senhor é minha força e somente Nele confio.

    • Marcado como Resposta Wilson Boris segunda-feira, 29 de outubro de 2012 16:14
    segunda-feira, 29 de outubro de 2012 15:49
  • Que bom que deu certo Wilson.

    Qualquer dúvida posta que te ajudamos.

    Abraços.


    Washington Luíz | MCP, MCTS
    O Senhor é minha força e somente Nele confio.

    • Marcado como Resposta Wilson Boris segunda-feira, 29 de outubro de 2012 16:53
    segunda-feira, 29 de outubro de 2012 16:46

Todas as Respostas

  • Veja se te ajuda

    http://www.brunoviegas.com.br/erro-could-not-load-type-xxx-default/


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    sábado, 27 de outubro de 2012 21:08
  • Olá Bruno,

    obrigado pelo retorno.

    onde eu configuro o IIS?

    sábado, 27 de outubro de 2012 21:23
  • Como você fez a publicação do seu sistema?


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    sábado, 27 de outubro de 2012 22:18
  • 1.DEPLOY
    -Primeiro passo:
    Botão direito em My Project 

    em Compile Configuration: Mudei de Debug para Release
    em Advanced Generate debug info: mudei de full para none
    O Framework do servidor 4.0
    -Segundo passo:
    Compilei com o Ctrl Shift B então criei na Pasta Bin da camada um Release para a produção
    -Terceiro Passo:
    WebConfig
    em <compilation> mudei debug para false

    2.PUBLISH

    - Quarto passo:

     botão direito em Publish File Systen
    Target Location criei uma pasta DEPLOY e OK

     

    sábado, 27 de outubro de 2012 22:26
  • Wilson, Boa tarde

    Depois você copiou o conteúdo desta pasta deploy para onde?

    Se foi para um servidor web, onde não tem acesso direto ao IIS, crie um SubDominio e jogue o conteúdo dentro da pasta que representa o subdominio

    Agora se for uma aplicação onde você tem o controle do IIS, Crie um Site no IIS apontando para o caminho da pasta Deploy, aqui tem um exemplo de como fazer isso http://technet.microsoft.com/pt-br/library/cc772350(v=ws.10).aspx

    Boa sorte


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    domingo, 28 de outubro de 2012 13:44
  • Bruno, boa tarde

    copiei para um provedor de hospedagem, o que eu fiz:

    o conteúdo da pasta bin os arquivos dll e xml eu tranferi para uma pasta bin

    e o conteúdo do deploy web e index eu tranferi para a pasta www

    Algo errado nisto?

    domingo, 28 de outubro de 2012 14:15
  • Teoricamente esta correto.

    Tente fazer a publicação através do próprio visual studio, escolha a opção FTP e faça a publicação


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    domingo, 28 de outubro de 2012 17:00
  • Ops, isso nunca fiz, onde localizo esta opção no Visual Studio Web Developer 2010?
    Seria com o botão direito sobre o projeto em Publish Web na caixa Publish em Publish Method na opção FTP ao invés de File System? Como fazer?
    • Editado Wilson Boris domingo, 28 de outubro de 2012 17:47 complemento
    domingo, 28 de outubro de 2012 17:36
  • Clica com o botão direito em cima do projeto e depois escolha a opção Publishi...

    Depois escolha a opção FTP e preencha os campos que vão aparecer


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    domingo, 28 de outubro de 2012 17:48
  • Bruno, nada feito,

    a mensagem continua:

     

    Server Error in '/' Application.



    Parser Error

    Description:
    An error occurred during the parsing of a resource required to service this
    request. Please review the following specific parse error details and modify
    your source file appropriately.

    Parser Error Message: Could not
    load type 'APBD.index'.

    Source Error:
    Line 1:  <%@ Page Language="vb" AutoEventWireup="false" CodeBehind="index.aspx.vb" Inherits="APBD.index" %>
    Line 2:  
    Line 3:  <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    Source
    File:
    /index.aspx    Line: 1




    Version Information: Microsoft .<a href="#" id="_GPLITA_0" in_rurl="http://i.trkjmp.com/click?v=QlI6MjU1MDY6MTQxNzpuZXQ6Yjg5N2JkZjFhMDI0NDUyMDRiNGE2MDgwN2IyOThkOWQ6ei0xMjY1LTk4MjUwOnd3dy5hcGJkaWFiZXRpY29zaGlwZXJ0ZW5zb3Mub3JnLmJyOjE1MDAwOmU4MmEyYzMyNDI4ODc3YjI1OGNkOGFlOWZkN2FmMjNk" title="Click to Continue > by Savings Sidekick">NET
    Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
    domingo, 28 de outubro de 2012 19:15
  • Você fez o Publish na pasta principal do servidor?

    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    domingo, 28 de outubro de 2012 22:12
  • Bruno, muito obrigado pelo apoio, isso está um drama.

    eu fiz o Publish em uma pasta que criei em meu projeto e após transferi com o FileZilla, pois dos campos requisitados eu só sabia o user name e password, já a URL eu não sei. eu solicitei ao meu provedor, mas ainda não tive retorno.

    Obs.:Eu tenho um outro domínio com o mesmo provedor e esta operação eu realizo normalmente com outro projeto:

           Outra questão que acho estranho é que estou é o próprio conteúdo que estou tentando publicar, poís é apenas uma página aspx com uma linha de texto com dois links com dois arquivos PDF. Não tem nada de código.

    domingo, 28 de outubro de 2012 22:27
  • Wilson,

    No seu servidor web, você publicou na pasta padrão do Servidor. Por Ex.: Imagine que a pasta padrão é a /WWW/, você publicou direto nesta pasta ou criou uma para publicar dentro Ex.: /WWW/MEUSITE/


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    domingo, 28 de outubro de 2012 22:58
  • Bruno,

    No FileZilla eu tenho no endereço local o conteúdo para transferir para o endereço remoto.

    No endereço remoto é carregado as seguintes pastas: banco, bin, www. Na pasta www tem uma subpasta denominada erros. Nesta raiz do endereço remoto eu acrescentei uma pasta biblioteca que contem dois arquivos PDF com os nomes:

    Oficiodivulgacao.pdf e Programacao.pdf.

    Na pasta www eu tranferi os arquivos APBD.dll e APBD.xml e na pasta bin os arquivos Index.aspx e Web.config.

    Na pagina Index.aspx tem o código abaixo para o link com os arquivos supracitados:

    <%@ Page Language="vb" AutoEventWireup="false" CodeBehind="index.aspx.vb" Inherits="APBD.index" %>

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml">
    <head runat="server">
        <title></title>
    </head>
    <body>
        <form id="form1" runat="server">
        <br />
        <br />
        <br />
        <br />
        <br />
        <br />
        <br />
        <br />
        <br />
        <br />
        <center>
        <div>
        INSCRIÇÕES ABERTAS<br />
            <strong>CURSO DE FORMAÇÃO DE CUIDADORES DE PORTADORES DE DIABETES E HIPERTENSÃO</strong><br />
            <br />
            Clique abaixo para:<br />
            <a href="Biblioteca/Oficiodivulgacao.pdf">Informação gerais</a><br />
            <a href="Biblioteca/Programacao.pdf">Programação</a><br />
            <br />
        </div>
        </center>
        </form>
    </body>
    </html>

    O arquivo Web.Config está da seguinte forma:

    <?xml version="1.0"?>

    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->

    <configuration>
        <system.web>
            <compilation debug="false" strict="false" explicit="true" targetFramework="4.0" />
            <customErrors mode="Off"/>
        </system.web>

    </configuration>

    Não é de acreditar, mas é só isso.



    • Editado Wilson Boris domingo, 28 de outubro de 2012 23:53 complemeto
    domingo, 28 de outubro de 2012 23:48
  • tente colocar a pagina Index.aspx na pasta Raiz, não na pasta bin

    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    domingo, 28 de outubro de 2012 23:58
  • Desculpe-me Bruno eu escrevi ao contrário:

    De: Na pasta www eu tranferi os arquivos APBD.dll e APBD.xml e na pasta bin os arquivos Index.aspx e Web.config.

    Para: Na pasta www eu tranferi os arquivos Index.aspx e Web.config. e na pasta bin os arquivos APBD.dll e APBD.xml

    Obs.: A Index.aspx está dentro da pasta www


    Fiz um PrtSc JPEG 150kb desta tranferencia, mas não está carregando no icone de imagem do Forum....  
    • Editado Wilson Boris segunda-feira, 29 de outubro de 2012 00:07 complemnto
    segunda-feira, 29 de outubro de 2012 00:04
  • Você pode mostrar dizer a url?

    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    segunda-feira, 29 de outubro de 2012 00:06
  • Wilson,

    O que parece é que esse Dominio não esta configurado corretamente

    Jà tentou publicar na sua maquina?


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    segunda-feira, 29 de outubro de 2012 10:09
  • Bom dia Bruno,

    eu acabei de fazer um Publish conforme recomendou FTP, mas sem sucesso. Qual o procedimento para publicar na minha máquina?

    Obs.:No endereço ftp: ftp://ftp.apbdiabeticoshipertensos.org.br/ posso observar a raiz e o conteúdo.

    segunda-feira, 29 de outubro de 2012 10:26
  • Instale o IIS.

    E através do gerenciador do IIS você cria um novo Site

    Para instalar o IIS, basta você instala-lo através do Painel de Controle > Programas ... > Recurso do Windows


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    segunda-feira, 29 de outubro de 2012 10:46
  • No painel de controle em desinstalar ou alterar um programa eu tenho 4 IIS na lista de Nomes os seguintes IIS:

    IIS URL Rewrite Module 2;

    IIS Express Application Compatibility Database dor x86;

    IIS Express Application Compatibility Database dor x64;

    IIS 8.0 Express.

    É neste local mesmo?

    segunda-feira, 29 de outubro de 2012 10:53
  • Qual windows que você usa?

    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    segunda-feira, 29 de outubro de 2012 11:31
  • Seven.

    segunda-feira, 29 de outubro de 2012 12:00
  • Segue esse tutorial aqui

    http://blog.computero.com.br/instalando-iis7-no-windows-seven/


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    segunda-feira, 29 de outubro de 2012 12:17
  • Ok Bruno,

    segui os passos sugeridos no blog, acho que sou portador do IIS e agora qual a minha espectativa de vida, rsrsrs?

    segunda-feira, 29 de outubro de 2012 12:34
  • Olá Wilson.

    Só por curiosidade, seu site no seu provedor possui uma estrutura semelhante a esta?

    Pasta www

       -> pasta Bin com dlls compiladas

       -> Outras pastas e arquivos do seu site

    Ou está assim?

    www

      -> Arquivos e pasta do site

    bin

      -> dlls compiladas

    segunda-feira, 29 de outubro de 2012 14:04
  • Abaixo eu fiz a estrutura da raiz do endereço remoto, sendo 1(pasta), 1.1(subpasta) e 2(conteúdo):

    1.banco

    1.Biblioteca

                     2.OficioDivulgacao.pdf

                     2.Programacao.pdf

    1.bin

                     2.APBD.dll

                     2.APBD.xml

    1.www

                    2.Index.aspx

                    2.Web.config

    1.1.erros

                    2.400.htm

                    2.401.htm

                    2.403.htm

                    2.404.htm

                    2.500.htm


    • Editado Wilson Boris segunda-feira, 29 de outubro de 2012 14:49 correçao
    segunda-feira, 29 de outubro de 2012 14:48
  • Olá Wilson.

    A estrutura correta, considerando que WWW é pasta configurada no seu servidor web como a pasta raiz da sua aplição, seria:

    estrutura de pastas

    Observe que a pasta WWW não entra na estrutura, pois ela é a pasta raiz do seu site. 

    Abraços.


    Washington Luíz | MCP, MCTS
    O Senhor é minha força e somente Nele confio.

    • Marcado como Resposta Wilson Boris segunda-feira, 29 de outubro de 2012 16:14
    segunda-feira, 29 de outubro de 2012 15:49
  • Washington, voce é gigante mesmo, 100%.

    Muito obrigado.

    Bruno, valeu amigo aprendi muito contigo, aguardo para possíveis sugestões quanto ao IIS.

     
    segunda-feira, 29 de outubro de 2012 16:13
  • Que bom que deu certo Wilson.

    Qualquer dúvida posta que te ajudamos.

    Abraços.


    Washington Luíz | MCP, MCTS
    O Senhor é minha força e somente Nele confio.

    • Marcado como Resposta Wilson Boris segunda-feira, 29 de outubro de 2012 16:53
    segunda-feira, 29 de outubro de 2012 16:46