none
css engoliu o background RRS feed

  • Pergunta

  • Galera, minha dúvida é a seguinte: Fiz um teste de um layout utilizando css (embutido, ou seja, dentro do próprio html). Várias divs e algumas com uma imagem como background. Ótimo, funcionou tudo perfeito. Migrei para minha página aspx, ou melhor, para minha masterpage.

    Criei a pasta App_Themes e nela o meu estilo css, logo as páginas pegaram todo o estilo de fonte, posição e todas as configurações, porém não apresenta as imagens de background.

    Já fiz todas as possibilidades de nome de arquivos e pastas, diversas combinações, mas nada adiantou.

    Caso alguém já tenha passado por este tipo de problema, eu ficaria grato por uma dica.

    quinta-feira, 30 de novembro de 2006 00:52

Todas as Respostas

  • Jeison, coloque o caminho para suas images da seguinte forma:

    background-image: url(/nome_aplicacao/diretorio_imagens/imagem.extensao);

    Onde nome_aplicação é o nome do diretório virtual da aplicação ou nome do projeto caso tenha sido criado no Visual Studio 2005 e utilize o servidor embutido no mesmo. Diretorio_imagens é o diretório ou restante do caminho para o diretório onde suas imagens estão, e imagem.extensao é o nome de seu arquivo.

    quinta-feira, 30 de novembro de 2006 10:19
  • Olá Juliano,

    Eu estava com um problema bem semelhante, criei um Masterpage e apliquei um background, porém nas páginas que eu utilizava o masterpage não aparecia o background. Mas com a sua dica, de colocar o caminho todo da aplicação, funcionou.

    valeu...

    segunda-feira, 5 de fevereiro de 2007 10:58