none
Fórmula para contar quantos lançamentos fez cada vendedor no mês RRS feed

  • Pergunta

  • Olá, boa noite

    Estou precisando de uma fórmula para contar quantas vezes foi lançado o nomes de 'Pedro' no mês "9"

    Ex;

    Data Vendedor
       
    01/09/2013 Pedro
    02/09/2013 Carlos
    03/09/2013 Pedro
    04/09/2013 Carlos 
    05/09/2013 Carlos
    06/09/2013 Pedro
    07/09/2013 Maria
    08/09/2013 Joao
    09/09/2013 Pedro
    10/09/2013 Lopes
    11/09/2013 Carlos 
    12/09/2013 Joao
    13/09/2013 Jose
    14/10/2013 Maria
    15/11/2013 Carlos
    16/11/2013 Pedro
    17/11/2013 Lopes
    18/11/2013 Carlos 
    19/11/2013

    Joao

    Link     http://www.4shared.com/file/WDeRxoFR/lanamentos.html

    Obrigado!
    • Editado miguelinho70 sexta-feira, 27 de setembro de 2013 18:15 agradecimentos
    sexta-feira, 27 de setembro de 2013 00:42

Respostas

  • Alternativa sem coluna auxiliar.

    Considere que os dados estão nas colunas A e B.

    Utilize a fórmula

    =SOMARPRODUTO(--(MÊS(A1:A19)=9);--(B1:B19="Pedro"))

    ou:

    =SOMA(SE((MÊS(A1:A19)=9)*(B1:B19="Pedro");1)) (pressione Ctrl+Shift+Enter para entrar com essa fórmula)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta miguelinho70 sexta-feira, 4 de outubro de 2013 16:09
    quarta-feira, 2 de outubro de 2013 02:52
    Moderador
  • Boa tarde Miguelinho.

    Uma forma simples de fazer isso é criar uma coluna de controle com as condições que você deseja e então usar uma fórmula para contar. No seu caso, supondo seus dados entre A2:B20, coloque a fórmula na coluna C, em C2:C20: =MÊS(A2)&B2; Em seguida use a fórmula para extrair o resultado: =CONT.SE(C2:C20;"9Pedro").

    Uma forma mais robusta e flexível de fazer isso é utilizar tabelas dinâmicas, mas isso depende da complexidade da sua necessidade.

    Um abraço.


    Filipe Magno

    • Marcado como Resposta miguelinho70 domingo, 29 de setembro de 2013 20:22
    domingo, 29 de setembro de 2013 17:01

Todas as Respostas

  • Boa tarde Miguelinho.

    Uma forma simples de fazer isso é criar uma coluna de controle com as condições que você deseja e então usar uma fórmula para contar. No seu caso, supondo seus dados entre A2:B20, coloque a fórmula na coluna C, em C2:C20: =MÊS(A2)&B2; Em seguida use a fórmula para extrair o resultado: =CONT.SE(C2:C20;"9Pedro").

    Uma forma mais robusta e flexível de fazer isso é utilizar tabelas dinâmicas, mas isso depende da complexidade da sua necessidade.

    Um abraço.


    Filipe Magno

    • Marcado como Resposta miguelinho70 domingo, 29 de setembro de 2013 20:22
    domingo, 29 de setembro de 2013 17:01
  • Resolveu a minha duvida. 

    Muitíssimo obrigado, Felipe

    Um abraço.

    domingo, 29 de setembro de 2013 20:27
  • Alternativa sem coluna auxiliar.

    Considere que os dados estão nas colunas A e B.

    Utilize a fórmula

    =SOMARPRODUTO(--(MÊS(A1:A19)=9);--(B1:B19="Pedro"))

    ou:

    =SOMA(SE((MÊS(A1:A19)=9)*(B1:B19="Pedro");1)) (pressione Ctrl+Shift+Enter para entrar com essa fórmula)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta miguelinho70 sexta-feira, 4 de outubro de 2013 16:09
    quarta-feira, 2 de outubro de 2013 02:52
    Moderador
  • Boa tarde a todos!

    Retornei a este Fórum para agradecer  com esta Formula, que inicialmente eu não tinha nada em mente para somar quantos vendedores venderam em um mês e assim por diante.

    Então com a ajuda de FELIPE conseguir chegar a esta formula.

    =SOMARPRODUTO(--(MÊS(Plan2!$A$4:$A$1000)=1);--(Plan2!$E$4:$E$1000=Plan1!A4))

    Na Plan1 fica a lista dos nomes dos vendedores com validação. Na Plan2 fica os lançamentos de todos os vendedores sendo na coluna 'A' inserir data, e na coluna 'E' os vendedores por validação. Finalmente o resultado que buscava. Na Plan3 coluna 'A' fica os nomes de todos os vendedores, na coluna 'B' à 'M' os meses. Então, entra a formula na célula 'B4' da Plan3

    Obrigado!

    sexta-feira, 4 de outubro de 2013 16:55