none
Aplicação WEB e WEB Service RRS feed

  • Pergunta

  • Pessoal, peguei uma aplicação para fazer manutenção e estou com um problema. É uma aplicação web e um webservice juntos. Na máquina de teste funciona perfeitamente, mas dentro do Visual Studio ocorre erros.

    Quando clico no link e o webservice é chamado sem problemas no servidor de testes. Mas quando executado dentro do Visual Studio, este link aponta para este servidor e não para LocalHost. Este até é um problema, mas o que realmente me incomoda é o fato de quando digito servidor/PaginaWebService.asmx funciona, mas dentro do Visual Studio (localhost:62612/PaginaWebService.asmx não. 

    Me parece que o web service não está subindo junto da aplicação. Como faço para, dentro do Visual Studio o serviço ser executado? Para consideração, ambos estão dentro da mesma solução.

    quarta-feira, 22 de outubro de 2014 13:22

Respostas

  • O Web service está em um projeto dentro da sua solution? Se sim, basta selecionar na solution, botão direito, properties -> Multiple startup projects e marque todos os projetos que devem ser inicializados.

    Marque como resposta se foi útil!

    • Sugerido como Resposta Deric Ferreira quarta-feira, 22 de outubro de 2014 13:39
    • Marcado como Resposta Eduardo C. Rocha quarta-feira, 22 de outubro de 2014 14:04
    quarta-feira, 22 de outubro de 2014 13:39

Todas as Respostas

  • O Web service está em um projeto dentro da sua solution? Se sim, basta selecionar na solution, botão direito, properties -> Multiple startup projects e marque todos os projetos que devem ser inicializados.

    Marque como resposta se foi útil!

    • Sugerido como Resposta Deric Ferreira quarta-feira, 22 de outubro de 2014 13:39
    • Marcado como Resposta Eduardo C. Rocha quarta-feira, 22 de outubro de 2014 14:04
    quarta-feira, 22 de outubro de 2014 13:39
  • Funcionou, o serviço subiu junto. Em outra porta, mas subiu. Agora preciso resolver como é feito o download do aplicativo.
    quarta-feira, 22 de outubro de 2014 15:56
  • Ótimo. Se quiser deixar fixo o número da porta. Botão direito no projeto -> properties -> Servers -> Use Visual Studio Development Server -> Specific Port.
    quarta-feira, 22 de outubro de 2014 16:01