none
FormsAuthentication, multiplos postback RRS feed

  • Pergunta

  • Boa tarde!

    Minha tela está carregando n vezes e eu não sei o motivo.

    Estou utilizando o FormsAuthentication, veja meu web config:

    <?xml version="1.0"?>
    <configuration>
        <location path="Default.aspx">
            <system.web>
                <authorization>
                    <allow users="*"></allow>
                </authorization>
            </system.web>
        </location>
        <location path="css">
            <system.web>
                <authorization>
                    <allow users="*"></allow>
                </authorization>
            </system.web>
        </location>
        <location path="img">
            <system.web>
                <authorization>
                    <allow users="*"></allow>
                </authorization>
            </system.web>
        </location>
        <location path="js">
            <system.web>
                <authorization>
                    <allow users="*"></allow>
                </authorization>
            </system.web>
        </location>
        <appSettings />
        <connectionStrings/>
        <system.web>
            <compilation debug="true" targetFramework="4.0">
                <assemblies>
                    <add assembly="mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                </assemblies>
            </compilation>
            <authentication mode="Forms">
                <forms name="CookieAuth" loginUrl="Default.aspx" timeout="60" />
            </authentication>
            <authorization>
                <deny users="?"/>
            </authorization>
            <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>
        </system.web>
        <system.serviceModel>
            <bindings />
            <client />
        </system.serviceModel>
    </configuration>

    Minha tela de logon é carregada 4x.

    O que tem de errado????

    Se removo isso : 

            <authorization>
                <deny users="?"/>
            </authorization>

    Carrega apenas uma vez, mas nao funciona mais o FormsAuthentication.

    Poderiam me ajudar por favor?

    Obrigado!



    quinta-feira, 25 de julho de 2013 17:23

Todas as Respostas