none
A VERSÃO MAIS RECENTE DO CRYSTAL REPORTS CONTEMPLA SEMPRE UMA VERSÃO ANTIGA? RRS feed

  • Pergunta

  • Estou com dúvidas aqui quanto à Utilização de Crystal de Report.

    Tenho uma máquina em casa (Window 8 - 64bits) onde desenvolvo. Pego o projeto dessa máquina e levo em um pendrive para o escritório.

    Porém comecei trabalhar com Crystal Reports recentemente e me deparei comum problema que parece não ter solução:

    Na máquina de casa eu consigo trabalhar e gerar meus relatórios normalmente. 

    Quando executo o programa nas máquinas do escritório (Win 7 64bits - todas) diretamente do executável roda normalmente tb, porém, quando eu abro o meu projeto na máquina do escritório que tem Visual Studio 2010 e recompilo, após recompilar o executável só roda nessa máquina (desenvolvedora), mas nas outras máquinas que não tem Visual Studio não roda mais dando o seguinte erro :

    Segue o texto do erro :

    Assinatura do problema:
      Nome do Evento de Problema:    CLR20r3
      Assinatura do Problema 01:    windowsapplication4.exe
      Assinatura do Problema 02:    1.0.0.0
      Assinatura do Problema 03:    526ea64c
      Assinatura do Problema 04:    WindowsApplication4
      Assinatura do Problema 05:    1.0.0.0
      Assinatura do Problema 06:    526ea64c
      Assinatura do Problema 07:    17
      Assinatura do Problema 08:    e9
      Assinatura do Problema 09:    System.InvalidOperationException
      Versão do sistema operacional:    6.1.7600.2.0.0.256.1
      Identificação da Localidade:    1046
      Informações Adicionais 1:    0a9e
      Informações Adicionais 2:    0a9e372d3b4ad19135b953a78882e789
      Informações Adicionais 3:    0a9e
      Informações Adicionais 4:    0a9e372d3b4ad19135b953a78882e789

    Leia nossa declaração de privacidade online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0416

    Se a declaração de privacidade online não estiver disponível, leia nossa declaração de privacidade offline:
      C:\Windows\system32\pt-BR\erofflps.txt

    Eu acredito que seja algum problema de compatibilidade de versão do Runtime do Crystal Report, porém já instalei a mesma versão de casa em todas as máquinas inclusive a desenvolvedora (O CR for VS2010 tb) e recompilei e continua com problema.

    Como faço pra comparar as versões do Crystal Report, tanto o Runtime quanto o Crystal Reports for Visual Studio?

    Como ter certeza que estou com as versões idênticas?

    Ou se eu usar sempre a versão mais recente do Runtime e o Crystal Reports for Visual Studio, irá funcionar?

    Eu utilizo Visual Studio 2010 Ultimate

    Todas as máquinas têm CRREDIST 64bit instalado e roda normal o executável, mas se eu recompilar na máquina do escritório aí o problema começa.

    Já pesquisei sobre o erro e tentei outras soluções, mas sem sucesso.

    Desde já, 

    Obrigado a todos.

    Geraldo Ribeiro




    segunda-feira, 28 de outubro de 2013 19:43

Todas as Respostas

  • ...

    A versão que tenho instalada na máquina de casa é : CRforVS_13_0_6_1027

    Consequentemente a versão do Runtime é a mesma, pois os dois são distribuídos juntos no mesmo pacote de instalação.

    ....

    O meu problema continua....

    segunda-feira, 28 de outubro de 2013 23:43
  • ...estou pensando em reinstalar o Visual Studio, será que resolveria?
    quarta-feira, 30 de outubro de 2013 13:04
  • Algum participante deste fórum poderia tentar me ajudar?

    Grato

    quarta-feira, 6 de novembro de 2013 00:10
  • Geraldo,

    Estou com exatamente esse problema, na maquina de desenvolvimento funciona tudo no Cliente da esse mesmo erro e trata-se de relatório em Crystal.

    Se eu conseguir alguma coisa eu posto e se conseguir alguma por favor me ajude.

    Obrigado

    quinta-feira, 7 de novembro de 2013 03:28