none
Como fazer um select no excel de uma outra planilha como fonte de dados que é carregada dinamicamente RRS feed

  • Pergunta

  • Minha duvida é a seguinte, tenho uma planilha que recebe uma massa de dados de um software, por exemplo as vendas feitas por contrato.

    contrato quantidade preco data
    5 8 100 janeiro
    6 10 120 janeiro
    7 8 120 fevereiro
    5 10 150 fevereiro
    7 10 150 marco

    E vou ter uma outra planilha que tem que agrupar alguns resultados e fazer alguns calculos

    exemplo:

    contrato preco medio bruto janeiro fevereiro marco
    5 250/18 8 10 0
    6 120/10 0 10
    7 270/18 0 8 10

    alguem sabe como fazer?

    quarta-feira, 25 de abril de 2012 18:59

Respostas

  • Considerando que "contrato" da base de dados está na coluna A e assim por diante, construa a tabela de resumo de seu exemplo onde "contrato" está em F1, 5 está em F2, etc.

    Em G2, use:=MÉDIASE($A$2:$A$6;$F2;$C$2:$C$6)&"/"&MÉDIASE($A$2:$A$6;$F2;$B$2:$B$6) (copie e cole a fórmula para baixo)

    Em H2, use: =SOMARPRODUTO(--($A$2:$A$6=$F2);--($D$2:$D$6=H$1);$B$2:$B$6) (copie e cole a fórmula para a direita e para baixo)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta José Arthur quinta-feira, 26 de abril de 2012 13:36
    • Não Marcado como Resposta José Arthur quinta-feira, 26 de abril de 2012 13:36
    • Marcado como Resposta José Arthur quinta-feira, 26 de abril de 2012 13:36
    quinta-feira, 26 de abril de 2012 00:19
    Moderador

Todas as Respostas

  • Considerando que "contrato" da base de dados está na coluna A e assim por diante, construa a tabela de resumo de seu exemplo onde "contrato" está em F1, 5 está em F2, etc.

    Em G2, use:=MÉDIASE($A$2:$A$6;$F2;$C$2:$C$6)&"/"&MÉDIASE($A$2:$A$6;$F2;$B$2:$B$6) (copie e cole a fórmula para baixo)

    Em H2, use: =SOMARPRODUTO(--($A$2:$A$6=$F2);--($D$2:$D$6=H$1);$B$2:$B$6) (copie e cole a fórmula para a direita e para baixo)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta José Arthur quinta-feira, 26 de abril de 2012 13:36
    • Não Marcado como Resposta José Arthur quinta-feira, 26 de abril de 2012 13:36
    • Marcado como Resposta José Arthur quinta-feira, 26 de abril de 2012 13:36
    quinta-feira, 26 de abril de 2012 00:19
    Moderador
  • funcionou corretamente, mas como eu disse os dados vem de uma outra base, entao a coluna contrato do relatório tambem tem que ser dinamica, tem uma forma de dar um distinct na coluna contrato da base de vendas e trazer para o relatorio para o relatorio?

    a coluna A1 possui o contrato das vendas e a F1 o contrato dos relatorios, quero trazer para F1 os contratos da venda.

    quinta-feira, 26 de abril de 2012 12:24
  • Se seu Excel for 2007 ou superior, crie uma Tabela (Alt, C, T e escolha o estilo de tabela) e use a fórmula:

    =SOMARPRODUTO(--(Tabela1[Colunas2]=cond1);--(Tabela1[Colunas2]=cond2)--(Tabela1[Colunas3]=cond3)) e assim por diante...

    Se o seu Excel for 2003, crie um Nome Definido atribuindo a ele, por exemplo, 

    ListaDinâmica1 atribuído à =DESLOC(Plan1!$A$1;0;0;CONT.VALORES(Plan1!$A:$A)-1;1)

    ListaDinâmica2 atribuído à =DESLOC(Plan1!$B$1;0;0;CONT.VALORES(Plan1!$B:$B)-1;1)

    ListaDinâmica3 atribuído à =DESLOC(Plan1!$C$1;0;0;CONT.VALORES(Plan1!$C:$C)-1;1)

    E então, use:

    =SOMARPRODUTO(--(ListaDinâmica1=cond1);--(ListaDinâmica2=cond2)--(ListaDinâmica3=cond3)) e assim por diante...


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    sexta-feira, 27 de abril de 2012 01:41
    Moderador