locked
Busca no Excel RRS feed

  • Pergunta

  • Boa tarde!

    Meu problema é o seguinte:

    Tenho uma planilha em excel que esta protegida por senha. Nessa planilha existem diversos dados sobre tarefas que as pessoas devem executar.

    O meu problema é que esta planilha se tornou longa e é necessario que a pessoa possa encontrar suas atividades por algum metodo de pesquisa ou filtro. O auto-Filtro não funciona em celulas protegidas. E o procv so funciona em uma linha por vez.


    =SE($A4<>"";PROCV($A4;Plan1!$HEmbarrassedI;2;FALSO);"")



      
    Eu gostaria que essa busca retornasse em outra guia todos os resultados com o nome da pessoa ou mesmo  utilizar o autofiltro.

    Como posso resolver este problema?
    quinta-feira, 27 de setembro de 2007 18:31

Todas as Respostas

  • http://aprendaexcel.com.br/Arquivos/Downloads/45_download.zip

    Porque você nao quebra a senha primeiro?!?
    sexta-feira, 28 de setembro de 2007 13:04
  • obrigado por responder!
    Eu já tenho a senha. O problema é que o filtro deverá ser aplicado com a planilha protegida . Não precisa ser um filtro eu posso simplesmente usar uma busca que retorne todas as atividades de uma determinada pessoa.
    sexta-feira, 28 de setembro de 2007 14:56
  • Ja tentou usar o comando Editar->Localizar ou simplesmente apertar crtl+l

    sexta-feira, 28 de setembro de 2007 18:21
  • Ou em VBA..

    sexta-feira, 28 de setembro de 2007 18:34
  • Ja tentei utilizar  o vba mas não sei como fazer pra efetuar a busca se alguem tiver qualquer sugestão por favor postem.
    sexta-feira, 28 de setembro de 2007 18:56
  • Põe ae uma linha da planilha.. pragente ver como é??
    sexta-feira, 28 de setembro de 2007 19:02
  • Olha

    quando voce protege a planilha, em ferramentas/proteger aparece uma caixa de dialogo para voce digitar a senha e escolher as opções, uma das opções é Usar Auto Filtro dae é só selecionar  e sair usando o auto filtro

    blz?

    falow

    XoX

     

    sexta-feira, 28 de setembro de 2007 19:23