none
Fonte de Dados para relatório Crystal Reports RRS feed

  • Pergunta

  • Bom dia a todos! Criei um Dataset tipado para servir de fonte de dados de meus relatórios(Data/Add new DataSource...). O DataSet está funcionando perfeitamente,Visualizo minhas tabelas e com a opção Preview Data visualizo os registros cadastrados no Banco de dados. Gero o relatório, escolho o dataset como minha fonte de dados mas quando clico na opção "Main Report Preview" visualizo o relatório da seguinte forma:

    idCliente NomeCliente CNPJ
    19.111 Fúcsia Tuesday
    23.674 Azul Thursday
    20.765 Cinza Sunday
    7.918 Amarelo Friday
    15.091 Verde Tuesday
    17.885 Azul Monday
    3.095 Verde-limão Tuesday
    23.693 Azul Esverdeado Saturday
    21.313 Verde Thursday
    9.606 Verde Monday

    Dados que não tem nada a ver com os dados no meu banco. Se alguém puder ajudar-me desde já agradeço! Utilizo o VS2010,WinForm, C#,MSACCESS,Crystal Reports.

    sexta-feira, 31 de agosto de 2012 12:48

Respostas

  • E ae tucão, blz cara?

    Quando eu trabalhei com Crystal era assim mesmo, como vc não tem dados, ele coloca dados ficticios para você poder visualizar como vai ficar o seu relatório.

    Então essa visualização não é a que vai ser gerado em tempo de execução, é só para você ter uma idéia de como vai ficar mesmo...


    Se a resposta foi útil por favor qualifique! Janderson Candido de Mattos - MCTS


    sexta-feira, 31 de agosto de 2012 13:00
  • Entendi, eu tive esse problema também, ele continua mostrando esses dados mesmo em execução neh, eu criei outro relatório para corrigir o problema, foi assim a solução que eu tive na época.

    Se a resposta foi útil por favor qualifique! Janderson Candido de Mattos - MCTS

    • Marcado como Resposta GdeP2004 sexta-feira, 31 de agosto de 2012 14:19
    sexta-feira, 31 de agosto de 2012 13:07

Todas as Respostas

  • E ae tucão, blz cara?

    Quando eu trabalhei com Crystal era assim mesmo, como vc não tem dados, ele coloca dados ficticios para você poder visualizar como vai ficar o seu relatório.

    Então essa visualização não é a que vai ser gerado em tempo de execução, é só para você ter uma idéia de como vai ficar mesmo...


    Se a resposta foi útil por favor qualifique! Janderson Candido de Mattos - MCTS


    sexta-feira, 31 de agosto de 2012 13:00
  • E ae tucão, blz cara?

    Quando eu trabalhei com Crystal era assim mesmo, como vc não tem dados, ele coloca dados ficticios para você poder visualizar como vai ficar o seu relatório.

    Então essa visualização não é a que vai ser gerado em tempo de execução, é só para você ter uma idéia de como vai ficar mesmo...


    Se a resposta foi útil por favor qualifique! Janderson Candido de Mattos - MCTS


    Mas o meu banco tem mais de 3.000 clientes cadastrados. Em execução tbm está saindo do mesmo jeito. Valeu!
    sexta-feira, 31 de agosto de 2012 13:05
  • Entendi, eu tive esse problema também, ele continua mostrando esses dados mesmo em execução neh, eu criei outro relatório para corrigir o problema, foi assim a solução que eu tive na época.

    Se a resposta foi útil por favor qualifique! Janderson Candido de Mattos - MCTS

    • Marcado como Resposta GdeP2004 sexta-feira, 31 de agosto de 2012 14:19
    sexta-feira, 31 de agosto de 2012 13:07
  • Entendi, eu tive esse problema também, ele continua mostrando esses dados mesmo em execução neh, eu criei outro relatório para corrigir o problema, foi assim a solução que eu tive na época.

    Se a resposta foi útil por favor qualifique! Janderson Candido de Mattos - MCTS

    Gerei outro relatorio, na visualização ainda está saindo errado mas em execução está tudo blz! Valeu,brigadão!
    sexta-feira, 31 de agosto de 2012 14:20
  • Que bom que funcionou brother, parabens!!!

    Se a resposta foi útil por favor qualifique! Janderson Candido de Mattos - MCTS

    sexta-feira, 31 de agosto de 2012 16:10