none
Erro Tipos Incompatíveis RRS feed

  • Pergunta

  • Prezados;

    Solicito ajuda em um problema que estou tendo após instalar o office2010 64bits.

    Ao abrir algumas planilhas que utilizo, passei a receber a msg "tipos incompatíveis".

    A planilha em anexo apresenta este problema, apenas em 64bits, e foi removido diversas macros.

    No VBA possui uma macro, "calculate", e um formulário.

    Se apagar qualquer um dos dois o problema desaparece, porém preciso dos dois.

    Agradeço quem puder me ajudar.

    Grato

    AdrianoPIres

    Anexo: www.sendspace.com/file/bf7dhs

    sábado, 16 de março de 2013 21:14

Respostas

  • Agradeço aos colegas benzadeus e Felipo Gonçalves pela atenção.

    Editei meu perfil e alterei o nome, vamos ver se aparece corretamente.

    Quanto ao meu problema, está ocorrendo com todas as planilhas que contenham macro e formulário (userform). estou achando que é algum problema em minha máquina. As macros e a segurança estão habilitadas.

    Minha esposa tem um pc exatamente igual ao meu, máquina, software, hardware e etc. e no dela não ocorre o problema só no meu.

    Vou restaurar o backup original e instalar tudo novamente, espero que resolva.

    Grato

    AdrianoPires

    Anexo: www.sendspace.com/file/2mv4c3 - www.sendspace.com/file/ori9ue - www.sendspace.com/file/3aue56

    terça-feira, 19 de março de 2013 02:18

Todas as Respostas

  • No meu Office 2010 32 bits a pasta de trabalho funciona normalmente.

    Em qual linha de código você recebe o aviso "tipos incompatíveis"?


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    segunda-feira, 18 de março de 2013 10:00
    Moderador
  • Bom dia! Tudo certinho?

    Primeiramente, bem vindo ao forum! Quando possível, acesse seu perfil (depois de logado, na direita tem um menu Meu Perfil e Minhas configurações). Tire uns minutos para edita-lo, pois seu nome está como o nome do post, então não sabemos quem você é.

    Quanto ao seu problema: baixei sua planilha e funcinou corretamente no meu Office 2010 64 bits, só precisei ativar duas  coisas, a parte de macro e a parte de segurança. Dai funcionou normal. Você consegue mandar um print do erro?

    Abraços!

    Felipo Gonçalves
    Microsoft Contingent Staff

    segunda-feira, 18 de março de 2013 13:17
    Moderador
  • Agradeço aos colegas benzadeus e Felipo Gonçalves pela atenção.

    Editei meu perfil e alterei o nome, vamos ver se aparece corretamente.

    Quanto ao meu problema, está ocorrendo com todas as planilhas que contenham macro e formulário (userform). estou achando que é algum problema em minha máquina. As macros e a segurança estão habilitadas.

    Minha esposa tem um pc exatamente igual ao meu, máquina, software, hardware e etc. e no dela não ocorre o problema só no meu.

    Vou restaurar o backup original e instalar tudo novamente, espero que resolva.

    Grato

    AdrianoPires

    Anexo: www.sendspace.com/file/2mv4c3 - www.sendspace.com/file/ori9ue - www.sendspace.com/file/3aue56

    terça-feira, 19 de março de 2013 02:18
  • Bom dia! Estamos aqui para isso! ;)

    Realmente acredito que seja a melhor solução você restaurar sua máquina. Como sua esposa tem uma maquina identica, provavelmente corrompeu a instalação na sua maquina.

    Vamos aguardar.

    Abraços!!

    Felipo Gonçalves
    Microsoft Contingent Staff

    terça-feira, 19 de março de 2013 12:02
    Moderador
  • Ok. Vou tentar.

    Obrigado.

    AdrianoPires

    quarta-feira, 20 de março de 2013 00:34