none
Erro ao instalar Visual Studio 2008 SP1 RRS feed

  • Pergunta

  • Boa noite senhores!
    Estou tentando instalar o Visual Studio 2008 SP1 porém me deparo com um erro na metade do processo enquanto está instalando o Microsoft .NET Framework 3.5 SP1.

    O log de erro segue abaixo:


    Exe (F:\vs90sp1\VC_x86Runtime.exe) succeeded.
    [2/22/2009, 19:32:26] (IronSpigot::ExeInstallerBase::PerformAction) Log File: dd_VC_x86RuntimeMSI168A.txt
    [2/22/2009, 19:32:26] (IronSpigot::ExeInstallerBase::PerformAction) Log File: dd_VC_x86RuntimeUI168A.txt
    [2/22/2009, 19:32:26] Action complete
    [2/22/2009, 19:32:26] (IronSpigot::RegKeyT<class ATL::CRegKey>::Evaluate) RegKey: HKLM\SOFTWARE\Microsoft\VisualStudio\9.0 exists.
    [2/22/2009, 19:32:26] Exists evaluated to true
    [2/22/2009, 19:32:26] (IronSpigot::ExeInstallerBase::ExeInstallerBase) Created new ExePerformer for Exe item
    [2/22/2009, 19:32:26] (IronSpigot::CartmanExeInstallerBase::CartmanExeInstallerBase) Created new CartmanExePerformer for Exe item
    [2/22/2009, 19:32:26] (IronSpigot::CartmanExeInstaller::CartmanExeInstaller) In CartmanExeInstaller::CartmanExeInstaller
    [2/22/2009, 19:32:26] (IronSpigot::CompositePerformerBaseT<class IronSpigot::MsiInstaller,struct IronSpigot::MspInstaller,struct IronSpigot::MultipleMspInstaller,class IronSpigot::ExeSelectingPerformer<class IronSpigot::ExeInstaller,class IronSpigot::CartmanExeInstaller> >::PerformAction) Created new ExePerformer for Exe item
    [2/22/2009, 19:32:26] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) In PreCreateProcess
    [2/22/2009, 19:32:26] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) m_pSetupWatcher->Connect succeeded
    [2/22/2009, 19:32:26] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = VC_x64Runtime.exe /q /progress CartmanSetupExeWatcher1678043162
    [2/22/2009, 19:32:26] (IronSpigot::CartmanExeInstallerBase::PostCreateProcess) PostCreateProcess succeeded
    [2/22/2009, 19:32:32] (IronSpigot::ExeInstallerBase::PerformAction) Exe log file(s) :
    [2/22/2009, 19:32:32] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\Antonio\AppData\Local\Temp\dd_VC_x64RuntimeMSI16A1.txt
    [2/22/2009, 19:32:32] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\Antonio\AppData\Local\Temp\dd_VC_x64RuntimeUI16A1.txt
    [2/22/2009, 19:32:32] (IronSpigot::ExeInstallerBase::PerformAction) Exe (F:\vs90sp1\VC_x64Runtime.exe) succeeded.
    [2/22/2009, 19:32:32] (IronSpigot::ExeInstallerBase::PerformAction) Log File: dd_VC_x64RuntimeMSI16A1.txt
    [2/22/2009, 19:32:32] (IronSpigot::ExeInstallerBase::PerformAction) Log File: dd_VC_x64RuntimeUI16A1.txt
    [2/22/2009, 19:32:32] Action complete
    [2/22/2009, 19:32:32] (IronSpigot::RegKeyT<class ATL::CRegKey>::Evaluate) RegKey: HKLM\SOFTWARE\Microsoft\VisualStudio\9.0 exists.
    [2/22/2009, 19:32:32] Exists evaluated to true
    [2/22/2009, 19:32:32] (IronSpigot::ExeInstallerBase::ExeInstallerBase) Created new ExePerformer for Exe item
    [2/22/2009, 19:32:32] (IronSpigot::CartmanExeInstallerBase::CartmanExeInstallerBase) Created new CartmanExePerformer for Exe item
    [2/22/2009, 19:32:32] (IronSpigot::CartmanExeInstaller::CartmanExeInstaller) In CartmanExeInstaller::CartmanExeInstaller
    [2/22/2009, 19:32:32] (IronSpigot::CompositePerformerBaseT<class IronSpigot::MsiInstaller,struct IronSpigot::MspInstaller,struct IronSpigot::MultipleMspInstaller,class IronSpigot::ExeSelectingPerformer<class IronSpigot::ExeInstaller,class IronSpigot::CartmanExeInstaller> >::PerformAction) Created new ExePerformer for Exe item
    [2/22/2009, 19:32:33] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) In PreCreateProcess
    [2/22/2009, 19:32:33] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) m_pSetupWatcher->Connect succeeded
    [2/22/2009, 19:32:33] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = VC_IA64Runtime.exe /q /progress CartmanSetupExeWatcher505728736
    [2/22/2009, 19:32:33] (IronSpigot::CartmanExeInstallerBase::PostCreateProcess) PostCreateProcess succeeded
    [2/22/2009, 19:32:37] (IronSpigot::ExeInstallerBase::PerformAction) F:\vs90sp1\VC_IA64Runtime.exe - Exe installer's log file/hint (%temp%\dd_VC_IA64Runtime*.txt|%temp%\..\dd_VC_IA64Runtime*.txt) does not exist or is invalid.
    [2/22/2009, 19:32:37] (IronSpigot::ExeInstallerBase::PerformAction) Exe (F:\vs90sp1\VC_IA64Runtime.exe) succeeded.
    [2/22/2009, 19:32:37] Action complete
    [2/22/2009, 19:32:37] (IronSpigot::RegKeyT<class ATL::CRegKey>::Evaluate) RegKey: HKLM\SOFTWARE\Microsoft\VisualStudio\9.0 exists.
    [2/22/2009, 19:32:37] Exists evaluated to true
    [2/22/2009, 19:32:37] (IronSpigot::ExeInstallerBase::ExeInstallerBase) Created new ExePerformer for Exe item
    [2/22/2009, 19:32:37] (IronSpigot::CartmanExeInstallerBase::CartmanExeInstallerBase) Created new CartmanExePerformer for Exe item
    [2/22/2009, 19:32:37] (IronSpigot::CartmanExeInstaller::CartmanExeInstaller) In CartmanExeInstaller::CartmanExeInstaller
    [2/22/2009, 19:32:37] (IronSpigot::CompositePerformerBaseT<class IronSpigot::MsiInstaller,struct IronSpigot::MspInstaller,struct IronSpigot::MultipleMspInstaller,class IronSpigot::ExeSelectingPerformer<class IronSpigot::ExeInstaller,class IronSpigot::CartmanExeInstaller> >::PerformAction) Created new ExePerformer for Exe item
    [2/22/2009, 19:32:37] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) In PreCreateProcess
    [2/22/2009, 19:32:37] (IronSpigot::CartmanExeInstallerBase::PreCreateProcess) m_pSetupWatcher->Connect succeeded
    [2/22/2009, 19:32:37] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = dotnetfx35.exe /q /norestart /lang:ENU /progress CartmanSetupExeWatcher1133710867
    [2/22/2009, 19:32:37] (IronSpigot::CartmanExeInstallerBase::PostCreateProcess) PostCreateProcess succeeded
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::EnsureExitCodeIsAnMSIErrorCode) Original exit code: F:\vs90sp1\dotnetfx35.exe returned non-MSI error code: 0x3712 - O armazenamento de componentes foi corrompido.
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) Exe log file(s) :
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\Antonio\AppData\Local\Temp\dd_dotnetfx35error.txt
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\Antonio\AppData\Local\Temp\dd_dotnetfx35install.txt
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\Antonio\AppData\Local\Temp\dd_depcheck_NETFX_EXP_35.txt
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) Exe (F:\vs90sp1\dotnetfx35.exe) failed with 0x80070643 - Erro fatal durante a instalação. .
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) Log File: dd_dotnetfx35error.txt
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) Log File: dd_dotnetfx35install.txt
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) Log File: dd_depcheck_NETFX_EXP_35.txt
    [2/22/2009, 19:40:20] (IronSpigot::ExeInstallerBase::PerformAction) PerformOperation on exe returned exit code 1603 (translates to HRESULT = 0x80070643)
    [2/22/2009, 19:40:20] Action complete
    [2/22/2009, 19:40:20] (IronSpigot::LogUtils::LogFinalResult) Final Result: Installation failed with error code: (0x80070643), Erro fatal durante a instalação.



    No dd_dotnetfx35error.txt tem:
    [02/22/09,19:39:58] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 14098




    Alguém pode me ajudar a desvendar o mistério?
    Obrigado :)




    domingo, 22 de fevereiro de 2009 22:43

Todas as Respostas

  • Olá;

    Primeiro tente isto:

    •     Faça uma limpeza no Windows Update temporary cache. Limpe o conteudo da pasta C:\Program Files\WindowsUpdate e da pasta temp do sistema operacional. (“Start” à “Run” à ”%temp%”).
    • Caso tenha um ant-virus instalado, desative-o temporáriamente para evitar os certos eventos causados por eles, principalmente o avast.
    • Em seguida tente instalar o NET Framework 3.5 SP1 novamente

    Você poderá encontrar mais sobre este problema e como resolvê-lo através deste link:
    http://social.msdn.microsoft.com/forums/en-US/vssetup/thread/f46b3f0b-105f-494c-9afb-233e4fd053f9

    Aconteceu o mesmo comigo e foi assim que consegui resolver. Espero ter te ajudado.

    Grato
    Samuel Diogo - CEO
    Datamar Trade Intelligence


    You have the skill. We Provide the tools
    • Sugerido como Resposta Samuel.diogo sábado, 14 de março de 2009 19:36
    segunda-feira, 23 de fevereiro de 2009 01:25
  • Oi Antônio


    Eu recomendo que primeiramente instale o  .NET Framework 3.5 SP1 primeiramente e depois efetue a instalação do service pack 1 do vs2008 e também desabilite o anti-virus e firewall enquanto realiza a instalação

    Espero que isso te ajude
    Juliana Prado Uchôa
    • Sugerido como Resposta Samuel.diogo sábado, 14 de março de 2009 19:37
    terça-feira, 10 de março de 2009 04:19