none
Erro em colunas de dados ao exportar um relatório para o Excel RRS feed

  • Pergunta

  • Boa noite a todos,

    Desenvolvemos alguns relatórios em Reporting Services para o Dynamics AX 2009. Após a apresentação do relatório em tela, escolhemos a opção exportar para Excel, ao abrir o arquivo gerado algumas colunas apresentam "#Valor". Isto acontece em um determinado ponto do arquivo e apartir dai as informações não são mais exibidas.

    Pensei que fosse um delay entre a geração dos dados e o processo de exportar o relatório mas não consegui neste caso. O relatório apresenta aproximadamente 370 páginas com 35 linhas em cada página. O volume de informações é grande e acredito que possa ser um fator para o erro.

    Alguém já precensiou algo parecido? Tem uma dica de como solucionar esta questão??

     

    Agradeço a ajuda.

    Itamar Lisboa

    quinta-feira, 19 de agosto de 2010 22:33

Respostas

  • Itamar,

    Qual é a tipo de dados que esta sendo utlizado neste coluna no seu relatório? Provavelmente a planilha no Excel este formatada para um tipo de dados incompatível com o dado ou com sua formatação, por exemplo, utilizar vírgula para separar valores ao invês de ponto.

    Isso é muito comum de ocorrer, inclusive, nos últimos dias estava utilizando o Excel 2010 para trabalhar com alguns cálculos e divido ao idioma da minha máquina(Inglês) e os valores que eu estavam passando em português, ocorria uma falha na realização do cálculo, retornando justamente este expressão #Valor.

    Normalmente é uma coisa bem simples que a gente não percebe.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário]
    • Marcado como Resposta Richard Juhasz sexta-feira, 25 de janeiro de 2013 16:01
    quarta-feira, 25 de agosto de 2010 13:18

Todas as Respostas

  • Itamar,

    fiz uma busca na internet e acho que o problema é de formatação:

    Tente trocar a formatação de #0 para N0.

    Por favor dê uma olha no link abaixo, que eu acho que é problema parecido com teu.

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/7aa7f32b-efd5-4f40-914c-ec62f0ee5e0c

    Atenciosamente,

    Vinícius Melo Juraszek

    Se tiver sido útil por favor marcar como respondido.
    sexta-feira, 20 de agosto de 2010 23:15
  • Bom dia Vinícius,

    Obrigado pelo retorno, estou validando as formatações dos campos em que estão ocorrendo o erro. Assim que finalizarem os testes, posto um retorno definitivo.

    Att.

    Itamar Lisboa

    segunda-feira, 23 de agosto de 2010 14:25
  • Boa tarde,

    Finalizei os testes porém o problema continua acontecendo. Percebi que ocorre sempre por volta da linha 1500 do relatório. Abaixo deste número de linha não notei o erro.

    Att.

    Itamar Lisboa

    segunda-feira, 23 de agosto de 2010 20:08
  • Itamar,

    Qual é a tipo de dados que esta sendo utlizado neste coluna no seu relatório? Provavelmente a planilha no Excel este formatada para um tipo de dados incompatível com o dado ou com sua formatação, por exemplo, utilizar vírgula para separar valores ao invês de ponto.

    Isso é muito comum de ocorrer, inclusive, nos últimos dias estava utilizando o Excel 2010 para trabalhar com alguns cálculos e divido ao idioma da minha máquina(Inglês) e os valores que eu estavam passando em português, ocorria uma falha na realização do cálculo, retornando justamente este expressão #Valor.

    Normalmente é uma coisa bem simples que a gente não percebe.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário]
    • Marcado como Resposta Richard Juhasz sexta-feira, 25 de janeiro de 2013 16:01
    quarta-feira, 25 de agosto de 2010 13:18