locked
Erro no Visual Studio que não entendo. RRS feed

  • Pergunta

  •  

    Pessoal,

     

    está ocorrendo um erro que não entendo no Visual Studio:

     

    Ao publicar (F5) ou visualizar pelo Blend, o projeto roda normalmente, agora no VS, tem esse erro que não sei a causa.

     

    Alguém sabe?

     

    Valeuuuu

    Fabio

    domingo, 14 de dezembro de 2008 14:35

Respostas

  • Mude o código para:

     

    <DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.RenderTransform).(TransformGroup.Children)[3].(TranslateTransform.X)" BeginTime="00:00:00" Storyboard.TargetName="desafio_btn">

    <SplineDoubleKeyFrame KeyTime="00:00:00" Value="0"/>

    <SplineDoubleKeyFrame KeyTime="00:00:00.4000000" Value="-171.5" KeySpline="0,0,0.5,1" />

    </DoubleAnimationUsingKeyFrames>

     

    Bruno
    segunda-feira, 15 de dezembro de 2008 22:11

Todas as Respostas

  • Tente mudar o código para

     

    <SplineDoubleKeyFrame ..... KeySpline="0,0,0.5,1" />

     

    Bruno

     

    segunda-feira, 15 de dezembro de 2008 13:54
  •  

    Bruno,

     

    tentei alterar aqui e ocorre mais erros ainda.

     

    Ou fiz errado ou não entendi o que vc quis dizer,
    se puder explicar novamente agradeço.

     

    Valeuuu

    Fabio

    segunda-feira, 15 de dezembro de 2008 15:57
  • Manda o pedaço de xaml que estava errado que eu mostro o que há

     

    Bruno

    segunda-feira, 15 de dezembro de 2008 17:06
  •  

    Bruno,

     

    é neste pedaço:

    Code Snippet

    <DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.RenderTransform).(TransformGroup.Children)[3].(TranslateTransform.X)" BeginTime="00:00:00" Storyboard.TargetName="desafio_btn">

    <SplineDoubleKeyFrame KeyTime="00:00:00" Value="0"/>

    <SplineDoubleKeyFrame KeyTime="00:00:00.4000000" Value="-171.5">

    <SplineDoubleKeyFrame.KeySpline>

    /////Aqui que ocorre

    <KeySpline>0,0,0.5,1</KeySpline>

    /////

    </SplineDoubleKeyFrame.KeySpline>

    </SplineDoubleKeyFrame>

    </DoubleAnimationUsingKeyFrames>

     

     

     

     

    Valeuu

    Fabio

    segunda-feira, 15 de dezembro de 2008 20:41
  • Mude o código para:

     

    <DoubleAnimationUsingKeyFrames Storyboard.TargetProperty="(UIElement.RenderTransform).(TransformGroup.Children)[3].(TranslateTransform.X)" BeginTime="00:00:00" Storyboard.TargetName="desafio_btn">

    <SplineDoubleKeyFrame KeyTime="00:00:00" Value="0"/>

    <SplineDoubleKeyFrame KeyTime="00:00:00.4000000" Value="-171.5" KeySpline="0,0,0.5,1" />

    </DoubleAnimationUsingKeyFrames>

     

    Bruno
    segunda-feira, 15 de dezembro de 2008 22:11
  • Brunão,

     

    2 noticias.

     

    - 1° Os Erros sumiram,

    alterei os lugares como você sugeriu e resolveu, os erros.

     

    - 2° Apareceu um novo erro,

    uma janela de erro aparece ao dar F5 no VS:

     

     

    Somente ocorre erro com este projeto, os demais testes e job funcionaram normal.


    Creio que é erro de instalção ou a versão que o programador usou dever ter um pequena diferença para o meu VS, se bem que segui os passos de instalação que ele mesmo me indicou.

     

    Tem como criar o .XAP pelo Blend ? pois de lá funciona corretamente.

     

    Valeuuu

    Fabio

    segunda-feira, 15 de dezembro de 2008 22:58
  • Sim, não há problema. Quando você dá F5, o XAP é gerado. É só usar ele.

     

    Bruno

     

    segunda-feira, 15 de dezembro de 2008 23:18