locked
Deixar valor 0223 como texto em celula sem que o valor mude para 223 tem como? RRS feed

  • Pergunta

  • Preciso exportar uma planilha do excel para xml mas toda vez que exporto os valores numéricos que possuem zero a esquerda estes perdem o zero da esquerda. A coluna está formata com um formato especial (personalizado) que adiciona o zero a esquerda nos casos que não para completar o número mínimo de caracteres que preciso que é 4. Mas se tento mudar o formato dos dados da coluna para texto é perdido os zeros da esquerda, se na celular está 0223 muda para 223. Tem como evitar isto? ou uma forma de exportar os dados desta coluna para o xml mantendo os zeros da esquerda?
    Paulo Moreira
    sexta-feira, 26 de novembro de 2010 16:52

Todas as Respostas

  • "A coluna está formata com um formato especial (personalizado) que adiciona o zero a esquerda nos casos que não para completar o número mínimo de caracteres que preciso que é 4"

    Paulo,

    Você concorda que a célula continua sendo 223, e o Excel mostra 0223 apenas visualmente porque você formatou a célula como tal?

    Experimente criar uma coluna auxiliar que referencie à coluna que possui valores usando a fórmula

    =TEXTO(A1;"0000")onde A1 possui o valor 223. Copie e cole a fórmula ao longo de toda coluna A.

    Em seguida, copie e cole especial como valores essa coluna no lugar da coluna A.

     


    http://www.ambienteoffice.com.br
    sexta-feira, 26 de novembro de 2010 20:45