none
serviço WCF no IIS RRS feed

  • Pergunta

  • Olá Pessoal!

    Sou iniciante no desenvolvimento WCF, e estou com o seguinte problema ao hospedar um serviço WCF no IIS.
    Quando invoco o serviço
    pelo browser, não aparece a página tradicional com o nome do serviço e as instruções para testá-lo, mas sim o código do arquivo *.svc.
    Eu preciso ativar alguma coisa no IIS pra ele reconhecer o serviço WCF?
    Estou usando o windows vista em minha máquina.

    Agradeço desde já,

    Att.

    segunda-feira, 10 de novembro de 2008 00:31

Respostas



  • Consegui encontrar o problema! 

    Caso, futuramente, alguém se deparar com a mesma situação, encontrei a solução neste forum -> http://forums.iis.net/t/1148343.aspx.

    O meu problema era porque não estava instalado o "
    WCF HTTP activation".
    Para instalá-lo é necessário ir em Painel de Controle -> Programas e Recursos, e ativar o recurso do Windows "WCF HTTP Activation" localizado em Microsoft .NET Framework 3.0.

    Muito Obrigada a todos pela atenção,

    Att.
    segunda-feira, 10 de novembro de 2008 02:57

Todas as Respostas



  • Consegui encontrar o problema! 

    Caso, futuramente, alguém se deparar com a mesma situação, encontrei a solução neste forum -> http://forums.iis.net/t/1148343.aspx.

    O meu problema era porque não estava instalado o "
    WCF HTTP activation".
    Para instalá-lo é necessário ir em Painel de Controle -> Programas e Recursos, e ativar o recurso do Windows "WCF HTTP Activation" localizado em Microsoft .NET Framework 3.0.

    Muito Obrigada a todos pela atenção,

    Att.
    segunda-feira, 10 de novembro de 2008 02:57
  • Obrigado pela ajuda Ada,

    Esse foi exatamente o meu problema. Apenas uma pequena correção, como apliquei em server 2008 deve-se ir até SERVER MANAGER>FEATURES  em seleciono .NET 3.0 em nas opções estará WCF HTTP ACTIVATION.

     

    Mais uma vez obrigado.

     

    Willian Rocha

    sexta-feira, 28 de janeiro de 2011 20:13