none
Invalid Report Source - Crystal Report RRS feed

  • Pergunta

  • Olá pessoal estou tendo problemas ao carregar uma tabela no crystal report, na hora em que vou chamar ele utilizando o crystalreportview ele dá a seguinte mensagem: "Invalid Report Source". Abaixo segue o código:

    foreach (Table tbCurrent in crRptResultado.Database.Tables)

    {

    tliCurrent = tbCurrent.LogOnInfo;

    tliCurrent.ConnectionInfo.DatabaseName = "DATABASE";

    tliCurrent.ConnectionInfo.ServerName = @"SERVIDOR\SQLSERVER2008";

    tliCurrent.ConnectionInfo.UserID = "SENHA";

    tliCurrent.ConnectionInfo.Password = "LOGIN";

    tbCurrent.ApplyLogOnInfo(tliCurrent);

    }

    crRepView.ReportSource = crRptResultado;

    crRepView.Refresh();

    O que será que pode estar acontecendo no VS2005 funciona normalmente.

     Abs.


    Rafael - MCTS.. Sua pergunta foi respondida ? Marque-a!
    terça-feira, 17 de março de 2009 16:56

Todas as Respostas

  • Ola Rafael,

    Acho, que esteja faltando  no seu código o SetDataSource.. Dê uma olhada no exemplo abaixo:

    SqlConnection conexao = new SqlConnection();  
    conexao.ConnectionString = stringConexao;  
    conexao.Open();  
    SqlDataAdapter da = new SqlDataAdapter(query, stringConexao);  
    conexao.Close();  
     
    DataSet dataReport = new DataSet();  
    da.Fill(dataReport);  
     
     
    CrystalReportCliente relatorio = new CrystalReportCliente();  
    relatorio.SetDataSource(dataReport);  
     
    crystalReportViewerClientes.ReportSource = relatorio;  
    crystalReportViewerClientes.Refresh();  
    crystalReportViewerClientes.RefreshReport();  
     


    Nelson Borges - Analista de Sistemas
    domingo, 22 de março de 2009 02:11