none
ERRO "Não existe mapeamento do tipo objeto " " para um provedor gerenciado de tipo nativo RRS feed

  • Pergunta

  • Se alguém por favor puder me ajudar agradeço. Estou com esse erro e não sei como resolvê-lo. Ele aparece quando vou executar a função "excluir" do meu projeto que ao não excluir, me retorna essa mensagem de erro. Estou usando o Visual studio 2012 e o Sql Server.
    segunda-feira, 1 de fevereiro de 2016 22:27

Respostas

  • Boa noite.

    Como falado pelo Kerplunk, ajudaria se fosse adicionado o código onde o erro ocorre.

    Porém este erro normalmente acontece quando há uma discrepância entre um tipo de parâmetro esperado e o valor do parâmetro adicionado.

    Verifique se todos os tipos coincidem ao executar as queries.


    Att., Rafael Simor

    • Marcado como Resposta Marcos SJ quarta-feira, 3 de fevereiro de 2016 18:02
    terça-feira, 2 de fevereiro de 2016 08:30
  • Boa tarde Diana,

    Pelo que vi, você não respondeu nenhum comentário feito. De qualquer maneira, como o SimorC já havia dito, provável que o valor esperado e passado não sejam do mesmo tipo.

    Para que você tenha mais consultas e referências sobre isso, sugiro que você olhe essa Thread;

    Atenciosamente,


    Roberto Alves

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta Marcos SJ quarta-feira, 3 de fevereiro de 2016 18:02
    quarta-feira, 3 de fevereiro de 2016 17:55

Todas as Respostas

  • Se puder passar a parte do código onde o erro ocorre, ajudaria.
    terça-feira, 2 de fevereiro de 2016 01:44
  • Boa noite.

    Como falado pelo Kerplunk, ajudaria se fosse adicionado o código onde o erro ocorre.

    Porém este erro normalmente acontece quando há uma discrepância entre um tipo de parâmetro esperado e o valor do parâmetro adicionado.

    Verifique se todos os tipos coincidem ao executar as queries.


    Att., Rafael Simor

    • Marcado como Resposta Marcos SJ quarta-feira, 3 de fevereiro de 2016 18:02
    terça-feira, 2 de fevereiro de 2016 08:30
  • Boa tarde Diana,

    Pelo que vi, você não respondeu nenhum comentário feito. De qualquer maneira, como o SimorC já havia dito, provável que o valor esperado e passado não sejam do mesmo tipo.

    Para que você tenha mais consultas e referências sobre isso, sugiro que você olhe essa Thread;

    Atenciosamente,


    Roberto Alves

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta Marcos SJ quarta-feira, 3 de fevereiro de 2016 18:02
    quarta-feira, 3 de fevereiro de 2016 17:55