locked
Configuração SQL Server 2008 R2 Express em Servidor RRS feed

  • Pergunta

  • Boa tarde. Estou desenvolvendo um sistema em delphi 7 com SQL Server 2008 Express R2.

    Usando componente ADO. Como Provider usei o Native SQL Client, devido a tambem usar no sistema, tabelas DBF, e como string de conexão escrevi: ".\SQLEXPRESS"

    Quando rodo a aplicação no servidor, ok. 

    Mas quando rodo em outra estação, dá o seguinte erro: "Ocorreu o seguinte erro: Provedor não encontrado. É possível que ele não esteja instalado corretamente"

    O que pode estar sendo necessário fazer?

    Obrigado

    Atte

    Renato Reis

    • Tipo Alterado Gustavo Maia Aguiar quarta-feira, 11 de janeiro de 2012 17:59 É uma dúvida e não uma discussão
    • Movido Gustavo Maia Aguiar quarta-feira, 11 de janeiro de 2012 17:59 (De:SQL Server - Desenvolvimento Geral)
    quarta-feira, 11 de janeiro de 2012 17:02

Todas as Respostas

  • Boa Tarde,

    Possivelmente o SQL Native Client não está instalado na outra estação.
    Adicionalmente, para conectar remoto, você terá que chamar Estacao\Express.

    Quando você usa .\EXPRESS, o "." informa que a máquina é local.

    [ ]s,

    Gustavo Maia Aguiar
    Blog: http://gustavomaiaaguiar.wordpress.com
    Vídeos: http://www.youtube.com/user/gmasql


    Classifique as respostas. O seu feedback é imprescindível
    quarta-feira, 11 de janeiro de 2012 17:59
  • Gustavo,

    Uso o IP na conexão. Estou em uma nova estação com Win7 32bits.

    Att

    terça-feira, 26 de março de 2013 19:43
  • Renato,

    Protocolo TCP/IP no SQL Server está habilitado? Tente fazer um telnet do servidor de app para o servidor de SQL.

    Ex: telnet nomeserver NumeroPortaSQL
          telnet SRV-SQL01 1433

    Se a resposta for util, classifique-a


    Att,
    Marcos Freccia [MTA|MCTS|MCITP|MCT SQL Server 2008]
    Blog|Twitter
    Assine também os feeds clicando aqui

    domingo, 21 de abril de 2013 03:10
  • Renato,

    Verifique se a porta 1433 esta liberada para acesso via firewall, como também se é esta a porta que esta configurada para o seu SQL Server utilizar através da ferramenta SQL Server Configuration Manager.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    terça-feira, 23 de abril de 2013 18:29
    Moderador
  • Para ver se a porta esta escutando.

    C:\Users\m4rc311> netstat -an | findstr 1433
      TCP    0.0.0.0:1433           0.0.0.0:0              LISTENING
      TCP    [::]:1433              [::]:0                 LISTENING


    Marcell Souza - Admin

    quinta-feira, 16 de maio de 2013 18:41
  • Para liberar no  firewall:

    O firewall do Windows do servidor SQL Server foi configurado com o scritp para liberar as portas:
    @echo =========  SQL Server Ports  ===================
    @echo Enabling SQLServer default instance port 1433
    netsh advfirewall firewall add rule name="SQL Server 1433" dir=in action=allow protocol=TCP localport=1433
    @echo Enabling Dedicated Admin Connection port 1434
    netsh advfirewall firewall add rule name="SQL Admin Connection 1434" dir=in action=allow protocol=TCP localport=1434
    @echo Enabling conventional SQL Server Service Broker port 4022  
    netsh advfirewall firewall add rule name="SQL Service Broker 4022" dir=in action=allow protocol=TCP localport=4022
    @echo Enabling Transact-SQL Debugger/RPC port 135
    netsh advfirewall firewall add rule name="SQL Debugger/RPC 135" dir=in action=allow protocol=TCP localport=135
    @echo Enabling SQL Server Named Pipes port 445
    netsh advfirewall firewall add rule name="Named Pipes port 445" dir=in action=allow protocol=TCP localport=445
    @echo =========  Analysis Services Ports  ==============
    @echo Enabling SSAS Default Instance port 2383
    netsh advfirewall firewall add rule name="SQL Analysis Services 2383" dir=in action=allow protocol=TCP localport=2383
    @echo Enabling SQL Server Browser Service port 2382
    netsh advfirewall firewall add rule name="SQL Browser TCP 2382" dir=in action=allow protocol=TCP localport=2382
    @echo Enabling port for SQL Server Browser Service's 'Browse' Button
    netsh advfirewall firewall add rule name="SQL Browser UDP 1434" dir=in action=allow protocol=UDP localport=1434
    @echo =========  Misc Applications  ==============
    @echo Enabling HTTP port 80
    netsh advfirewall firewall add rule name="SQL HTTP 80" dir=in action=allow protocol=TCP localport=80
    @echo Enabling SSL port 443
    netsh advfirewall firewall add rule name="SQL SSL 443" dir=in action=allow protocol=TCP localport=443
    @echo Allowing multicast broadcast response on UDP (Browser Service Enumerations OK)
    netsh advfirewall set currentprofile settings unicastresponsetomulticast enable

    rem Arquivos para liberar
    rem %ProgramFiles% (x86)\Microsoft SQL Server\90\Shared\sqlbrowser.exe
    rem %ProgramFiles%\Microsoft SQL Server\MSSQL11.SQLEXPRESS\MSSQL\Binn\sqlservr.exe


    Marcell Souza - Admin

    quinta-feira, 16 de maio de 2013 18:42
  • Marcell, boa tarde.

    Postei novo tópico sobre o mesmo assunto e achei sua resposta neste tópico, referente a um mesmo problema que tive no servidor anterior.

    Nesta sua resposta como e onde devo executar esses comandos?

    Obrigado.

    segunda-feira, 9 de fevereiro de 2015 14:30