none
Erro "could not load type" RRS feed

  • Pergunta

  • Pessoal, eu tenho uma aplicação que em minha máquina funciona corretamente. Porém quando eu a coloco em um servidor Windows 7 vem a mensagem 'Could not load type 'FrmLogin'. O problema é que funciona corretamente tanto quando eu executo no Visual Studio como quando eu coloco em um outro servidor. Alguém imagina o que pode estar ocorrendo?

    segunda-feira, 8 de abril de 2013 13:50

Todas as Respostas

  • A aplicação é Web ou DeskTop , se for web veja se o asp.net dessa máquina está instalado com a mesma versão do seu .NetFramework quando você instalou e use

    o AspNet_RegIIS veja se isso lhe ajuda :

    http://msdn.microsoft.com/pt-br/library/k6h9cz8h(v=vs.100).aspx

    OBS : Se for web , senão desconsidere.

    Espero ter ajudado.


    Davi Murilo Referência Principal : Jesus que ilumina minha mente.
    Referência Profissonal : http://www.tidm.com.br

    segunda-feira, 8 de abril de 2013 13:59
  • A aplicação é Web ou DeskTop , se for web veja se o asp.net dessa máquina está instalado com a mesma versão do seu .NetFramework quando você instalou e use

    o AspNet_RegIIS veja se isso lhe ajuda :

    http://msdn.microsoft.com/pt-br/library/k6h9cz8h(v=vs.100).aspx

    OBS : Se for web , senão desconsidere.

    Espero ter ajudado.


    Davi Murilo Referência Principal : Jesus que ilumina minha mente.
    Referência Profissonal : http://www.tidm.com.br

    Davi, a versão do Asp esta correta sim "Version:4.0.30319.1" eu até reiniciei várias vezes mas não tem nada que me resolva este problema. Obrigado pelo tempo dispensado a me ajudar.

    segunda-feira, 8 de abril de 2013 14:07
  • Certo mas só por via das tente rodar o comando : aspnet_regiis -i no prompt do Visual Studio Prompt.

    Davi Murilo Referência Principal : Jesus que ilumina minha mente.
    Referência Profissonal : http://www.tidm.com.br

    segunda-feira, 8 de abril de 2013 14:14
  • Certo mas só por via das tente rodar o comando : aspnet_regiis -i no prompt do Visual Studio Prompt.

    Davi Murilo Referência Principal : Jesus que ilumina minha mente.
    Referência Profissonal : http://www.tidm.com.br

    Não infelizmente não funcionou. E para mim não faz o menor sentido funcionar em um lugar e não funcionar no outro... Obrigado pela atenção
    segunda-feira, 8 de abril de 2013 15:12
  • Olá Eduardo...

    Verifique se a classe referenciada no arquivo .aspx está correta em relação a classe que está no arquivo aspx.cs.

    Repare que na declaração abaixo, o CodeBehind está no arquivo FrmLogin.aspx.cs e a classe do Formulário é a Sistema.Seguranca.FrmLogin.

    <%@ Page language="c#" Codebehind="FrmLogin.aspx.cs" AutoEventWireup="True" Inherits="Sistema.Seguranca.FrmLogin" %>

    Abraço!!!
    segunda-feira, 8 de abril de 2013 20:37
  • Verifica se seu web.config esta configurado para usar auteticação por formulario e se as permissoes do IIS aceita esse tipo de autenticação
    quarta-feira, 10 de abril de 2013 15:54