none
Erro - Report Service - SharePoint 2013 RRS feed

  • Pergunta

  • No SharePoint 2013, ao fazer o Deploy de um relatório do Report Services, mapeando como localhost o root site, eu consigo chamar o relatório, se no "Site Bindings" do IIS existir um parâmetro onde todos os hosts apontem para o site em questão.

    Como esse cenário não era possível no ambiente de produção, já que existem outros sites, retiramos este "Site Binding", e o parâmetro "localhost" no mapeamento, passsou a não ser mais efetivo.

    Como solução, nós passamos a pegar o contexto do site através de um script, que funcionou nos ambiente de desenvolvimento, integração e homologação, porém quando subimos o relatório para produção, o mesmo não exibe a seguinte mensagem de erro:

    Erro no processamento de relatório. (rsProcessingAborted)
    Falha na execução da consulta para o conjunto de dados 'obterRegistrosValidacaoDataSet'. (rsErrorExecutingCommand)
    Failed to execute web request for the specified URL. Not Found: The remote server returned an error: (404) Not Found. (rsXmlDataProviderError)
    For more information about this error navigate to the report server on the local server machine, or enable remote errors

    Após análise, verificamos que a diferença existente nos ambientes de (Desenvolvimento, Integração Homologação) para Produção é que o servidor de produção está em um cluster e nos outros ambientes em que o relatório funciona, estão em um host único.

    Alguma ideia sobre o que devo fazer para resolver esse problema?


    Att

    quarta-feira, 16 de setembro de 2015 18:07

Todas as Respostas