none
Iteração entre Frameworks 3.5 e 4.x RRS feed

  • Pergunta

  • Prezados membros da comunidade, bom dia. 

    Antes de mais nada, quero desculpar-me se coloquei minha dúvida no lugar errado, mas acredito que aqui é onde mais se encaixa.

    Eu tenho uma aplicação já pronta, em produção, desenvolvida no Framework 3.5, Visual Studio 2008. O Sefaz recentemente mudou o protocolo de comunicação para TLS 1.2, por razões de segurança, protocolo esse que o Framework 3.5 não dá suporte. 

    A atualização da aplicação para o Visual Studio 2017 não é uma opção. Teria que ser toda desenvolvida, do zero, devido ao fato de os programadores anteriores terem usado o DevExpress 9.x, que não é compatível também com o VS 2017. 

    Assim sendo, minha pergunta é: Eu consigo usar uma dll feita no VS 2017, dentro da aplicação VS 2008, como já fiz no Visual Basic 6.0? Existe essa possibilidade?

    Desde já, eu agradeço por qualquer ajuda.

    terça-feira, 15 de maio de 2018 12:50