locked
load operation failed query getuser remote server returned error notfound RRS feed

  • Pergunta

  • Boa tarde!!

    Depois de muuuiito tempo consegui concluir  uma tela que efetua uma consulta via nome do cliente. Quando executo localmente da tudo certo, porém quando publiquei a aplicação e tentei acessar de outra máquina dá o seguinte erro:

    load operation failed query getuser remote server returned error notfound

    Alguém já passou por essa?

    Estou usando VS2010, WCF + Silverlight 4.0

    Obrigado,

     

    terça-feira, 13 de julho de 2010 20:06

Respostas

  • Você está usando um WCF publicado normal ou .Net Ria Services?

    De qualquer forma pode estar faltando alguma coisa na configuração do seu servidor.

    Você consegue enxergar o WSDL do seu SVC?

    Tente navegar até o serviço usando http://www.seusite.com/seuservico.svc e veja se ele está exibindo as informações do serviço no navegador.

    Se estiver usando Ria Services tem 2 coisas que você precisa conferir.

    No IIS você só pode ter 1 tipo de autenticação habilitado. Ou seja, mantenha o usuário anônimo e desmarque a opção de Windows Authentication.

    Para navegar até o servico, a url seria algo assim: http://seusite.com/Namespace-da-classse-do-servico-seuservico.svc

    Neste caso a classe do seu serviço estaria no Namespace Namespace.da.classe.do.servico e a classe se chamaria Seuservico.svc

    []´s


    Ricardo Dorta
    Arquiteto de Software
    MCP,MCAD,MCSD
    Ajudou? Marque como reposta!!!.
    blog: http://blogs.makesys.com.br/dorta
    twitter : http://twitter.com/dortaway
    • Marcado como Resposta Daniel Ferreira terça-feira, 13 de julho de 2010 23:28
    terça-feira, 13 de julho de 2010 20:52

Todas as Respostas

  • Você está usando um WCF publicado normal ou .Net Ria Services?

    De qualquer forma pode estar faltando alguma coisa na configuração do seu servidor.

    Você consegue enxergar o WSDL do seu SVC?

    Tente navegar até o serviço usando http://www.seusite.com/seuservico.svc e veja se ele está exibindo as informações do serviço no navegador.

    Se estiver usando Ria Services tem 2 coisas que você precisa conferir.

    No IIS você só pode ter 1 tipo de autenticação habilitado. Ou seja, mantenha o usuário anônimo e desmarque a opção de Windows Authentication.

    Para navegar até o servico, a url seria algo assim: http://seusite.com/Namespace-da-classse-do-servico-seuservico.svc

    Neste caso a classe do seu serviço estaria no Namespace Namespace.da.classe.do.servico e a classe se chamaria Seuservico.svc

    []´s


    Ricardo Dorta
    Arquiteto de Software
    MCP,MCAD,MCSD
    Ajudou? Marque como reposta!!!.
    blog: http://blogs.makesys.com.br/dorta
    twitter : http://twitter.com/dortaway
    • Marcado como Resposta Daniel Ferreira terça-feira, 13 de julho de 2010 23:28
    terça-feira, 13 de julho de 2010 20:52
  • Sua aplicação cliente não esta encontrado o ria services. Verifique o Web.config se estão corretos os providers e etc.
    terça-feira, 13 de julho de 2010 20:53