none
Combobox no Datagridview não acessível RRS feed

  • Pergunta

  • Bom dia.

    Criei em um form um datagridview com uma coluna do tipo combobox, esse datagrid será preenchido com valores de uma tabela porém o combobox terá valor fixo independente dos valores da tabela, sendo assim na propriedade items da coluna comobobox informei os valores.

    O problema é que quando executo o programa não consigo selecionar nada no combobox, ele aparenta estar desabilitado, alguém pode me ajudar.

    Obrigado.

    quarta-feira, 16 de setembro de 2015 13:10

Respostas

  • Olá, Gustavo!

       Quando tive este problema (mas utilizando Visual Studio e C#), a solução foi definir a propriedade ReadOnly do datagrid como false, e alterar a propriedade ReadOnly das colunas individualmente.

    Espero que ajude.

    • Marcado como Resposta Marcos SJ quarta-feira, 16 de setembro de 2015 17:36
    quarta-feira, 16 de setembro de 2015 14:36
  • Ou verifique a propriedade do grid Enable se não está igual a false.

    Bruno Ferreira de Souza
    MVP - Microsoft Valuable Professional
    MCTS .NET Framework - Windows Applications
    MCPD .NET Framework - Windows Applications
    www.maestrodotnet.com.br
    @BrunoMaestro

    • Marcado como Resposta Marcos SJ quarta-feira, 16 de setembro de 2015 17:37
    quarta-feira, 16 de setembro de 2015 16:16

Todas as Respostas

  • Olá, Gustavo!

       Quando tive este problema (mas utilizando Visual Studio e C#), a solução foi definir a propriedade ReadOnly do datagrid como false, e alterar a propriedade ReadOnly das colunas individualmente.

    Espero que ajude.

    • Marcado como Resposta Marcos SJ quarta-feira, 16 de setembro de 2015 17:36
    quarta-feira, 16 de setembro de 2015 14:36
  • Ou verifique a propriedade do grid Enable se não está igual a false.

    Bruno Ferreira de Souza
    MVP - Microsoft Valuable Professional
    MCTS .NET Framework - Windows Applications
    MCPD .NET Framework - Windows Applications
    www.maestrodotnet.com.br
    @BrunoMaestro

    • Marcado como Resposta Marcos SJ quarta-feira, 16 de setembro de 2015 17:37
    quarta-feira, 16 de setembro de 2015 16:16
  • Obrigado funcionou!
    quinta-feira, 17 de setembro de 2015 10:48