locked
macro que completa-se RRS feed

  • Pergunta

  • boa a todos

    tenho um problema que talvez seja facil de se resolver: tenho 2 plan: na 1 tenho a seguinte relação:

         a         b              c

    1   1     titulo 1     20/03

    2   2     titulo 2     25/04

    3   3     titulo 3    

    na plan 2, é marcado o numero do titulo (a) e preenchido quando ele será executado, ex:

               a               b                   c

        1 03/05      fulano de tal    no do titulo

    é possivel isso com uma macro, ou nem preciso dela? ajudem-me. obrigado

    segunda-feira, 2 de maio de 2011 12:03

Todas as Respostas

  • Você pode fazer isso usando a fórmula PROCV no excel.

    Faça assim:

    Na Plan2, na célula B1 coloque a seguinte fórmula

    =PROCV(A1;Plan1!$B$8:$N$500;2;falso)

    Na célula C1 coloque a seguinte fórmula

    =PROCV(A1;Plan1!$B$8:$N$500;3;falso)

    e na célula C1  

    =PROCV(A1;Plan1!$B$8:$N$500;3;falso)

     

    Dê uma olhadinha e veja se te ajudou.

    Qualquer coisa posta novamente, que a gente tenta te ajudar.

    Abraço.

     

    Se ficou como queria, não esqueça de marcar como respondido.

    segunda-feira, 2 de maio de 2011 12:19
  • Acho que entendi sua formula e até testei, mas acho que ainda não chegamos num concenso, mas agradeço e espero que continue a me ajudar, vou tentar explicar de novo, agora com mais detales:

    plan 1-tem o nome de titulos

       a                        b                c            d           e        

        n do tit.     nome do tit.       2009      2010     2011

    1      1              titulo 1          20/03           

    2      2              titulo 2                     25/04

    3      3              titulo 3          20/09

    4      4              titulo 4                                   03/01

     os titulo tem nomes diferente e são relacionados 1 a 180, na verdade eu so preciso que atualize a data do ano de 2011 ou corrente:

    plan 2 - tem o nome marcação

    mes de janeiro

        linha        a               b                   c

       coluna

         1        03/01      fulano de tal    no do titulo

         2       10/01       beltrno melo    no do titulo

         3       20/01       roberval          no do titulo

    eu preciso que na hora em que eu digite o numero do titulo na plan 2 (marcação) ele atualize o ano corrente na plan 1 com a data.

    tentei o procv e a formula se, mas são muitos possibilidades, como disse 180, por isso pensei numa macro.

     

     

     

     

    segunda-feira, 2 de maio de 2011 14:42
  • Bom.. você pode me mandar a planilha por e-mail?

    alvaro.horta@yamana.com

    vendo a planilha fica mais fácil.

    Abraço

    segunda-feira, 2 de maio de 2011 16:28
  • tenho certeza que ficaria até mais facil, mas vc não consegue me da uma ideia atraves deste exemplo
    segunda-feira, 2 de maio de 2011 20:10
  • Pelo que entendi, na plan2 você informa quando um título que está presente na plan1 será executado. É isso mesmo ? 

     

    Se for isso, o que vc tem que fazer é colocar o procv() na plan1 e não na plan2. Em suma, vc vai procurar na plan2 quando o título será executado. Se ele achar a data de execução, ele preenche a coluna com a data. Senão, ele vai deixar em branco.

     

    Por favor, verifique que o problema não está na resposta e sim na pergunta. Sua pergunta está confusa. Se você caprichar mais na pergunta a gente bola uma resposta.

     


    João Eurico Consultor Manguetown - Brazil
    quarta-feira, 4 de maio de 2011 00:42