none
Mudança de framework da aplicação RRS feed

  • Pergunta

  •  

    Olá pessoal, blz?

     

    Meu problema é o seguinte....

     

    Vou implementar funcionalidades em um sistema desenvolvido com VS 2008 e CF 3.5.

     

    Acontece que os componentes que o fabricante disponibiliza no SDK do equipamento não tem suporte para o CF3.5, só para o CF 2.0.

     

    Com isso preciso mudar o framework dessa aplicação de 3.5 para 2.0 , é possível? Como?

     

     

    Desde já agradeço

     

    Wescley Arruda

    domingo, 25 de janeiro de 2009 03:48

Todas as Respostas

  • Wescley,

    Eu acredito que não seja possível, pois quando você cria uma solução em 3.5, o VS acrescenta algumas cláusulas using, como a do Linq.

    Talvez o que você possa fazer é criar uma class library (DLL) em 2.0 só para implementar o SDK do equipamento e referenciá-la no seu projeto 3.5.

    []s,

    segunda-feira, 26 de janeiro de 2009 11:01
  • Olá Carlos, obrigado pela resposta.

     

    Só para explicar um pouco mais sobre o SDK...

     

    Para utilizar o SDK em uma aplicação faço as referências no projeto (dll's) e depois adiciono na Toolbox através das Dll's do SDK e dessa forma consigo direto da Toolbox arrastar um componente para o form, depois é só programar.

     

    Da forma como você comentou, terei como adicionar na Toolbox e arrastar para um form?

     

    Será que fui claro?

     

    PS.: O pior é que acabei de receber um mail do suporte do fabricante informando que não irão fazer mudanças no SDK para que seja usado no CF 3.5, pelo menos até o final desse ano Sad

     

    Desde já obrigado!

     

    Wescley Arruda

     

    segunda-feira, 26 de janeiro de 2009 17:08
  • Wescley,

    Você não precisa adicionar o componente na toolbox para poder utilizá-lo, a não ser que seja visual, é o caso?

    []s,

    segunda-feira, 26 de janeiro de 2009 19:55
  • Olá Carlos,

    Sim, meu componente é visual...

     

    Será que existe alguma maneira ou realmente terei que "portar" a aplicação para o framework 2.0?

     

     

    Obrigado!

     

    terça-feira, 27 de janeiro de 2009 00:34
  •  

    Só para adicionar...No Vs 2008 existe a possibilidade de mudar o framework da aplicação, encontrei a informação nos links abaixo:

    http://www.onteorasoftware.net/post/Change-the-Framework-Version-of-a-Project-in-VS-2008.aspx

     

    http://msdn.microsoft.com/en-us/library/bb398202.aspx

     

    Mas ai vem o porém.....em uma aplicação Compact framework não fica habilitada a drop de target framework.

     

    Será que alguém aqui já utilizou essa opção em projeto Mobile????

     

    abs

     

    Wescley

    quarta-feira, 28 de janeiro de 2009 02:38