none
Intercepçao RRS feed

  • Pergunta

  • Bom Dia, 

    No excel existe uma funçao chamada intercepçao que calcula o ponto no qual uma linha irá interceptar o eixo y usando valores de x e y existentes.

    Estou criando uma query de previsão de demanda, baseado em um modelo de sazionalidade e preciso fazer esse calculo.Alguem poderia me dar uma luz como fazer no sql?

    caso facilite seque a formula que uso no excel pro calculo da previsao

    =SE(A3=1;(INTERCEPÇÃO($B$3:$B$38;$A$3:$A$38)+INCLINAÇÃO($B$3:$B$38;$A$3:$A$38))*C3;1)

    sendo coluna A o tempo em meses ( de 1 a 48 meses)

    coluna B a demanda real

    e coluna C a media da sazonalidade

    quinta-feira, 3 de dezembro de 2015 12:54

Respostas

  • Julia,

    Você esta realizando o cálculo no Excel e deseja que o SQL Server receba o dado já calculado e formatado?


    Pedro Antonio Galvao Junior [MVP | MCC | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitario | SoroCodigos | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    • Marcado como Resposta Marcos SJ segunda-feira, 7 de dezembro de 2015 12:39
    sexta-feira, 4 de dezembro de 2015 14:33

Todas as Respostas

  • juliafb,

    Você descreveu um cenário mas não explicou qual o erro/problema gerado para que a comunidade possa te auxiliar.

    Atenciosamente


    Marcos Roberto de Souza Junior

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 3 de dezembro de 2015 16:34
  • Julia,

    Você esta realizando o cálculo no Excel e deseja que o SQL Server receba o dado já calculado e formatado?


    Pedro Antonio Galvao Junior [MVP | MCC | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitario | SoroCodigos | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    • Marcado como Resposta Marcos SJ segunda-feira, 7 de dezembro de 2015 12:39
    sexta-feira, 4 de dezembro de 2015 14:33
  • Bom dia,

    Por falta de retorno do usuário, esta thread será encerrada.

    Caso seja necessário, por gentileza, abra uma thread nova.

    Atenciosamente

    Marcos Roberto de Souza Junior

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 7 de dezembro de 2015 12:38