none
Erro no Email Router - EmailUser RRS feed

  • Pergunta

  • Pessoal,

    Instalei o E-mail router e fiz a configuração porém ao fazer o teste na guia "Usuários, Filas e Caixas de Correio de Encaminhamento" da o seguinte erro: "O parâmetro de configuração "EmailUser" do serviço E-mail Router está ausente. Esse parâmetro é necessário"

    Tentei habilitar o opção "Permitir Email roteador para usar minhas credenciais para enviar e receber email em meu nome" em Ferramenta / Opções / Email, conforme KB da MS - http://support.microsoft.com/kb/947094. Porém este item está desabilitado não consigo habilitar. 

    O que devo fazer?


    Luiz Henroqie

    quinta-feira, 26 de abril de 2012 13:21

Todas as Respostas

  • Ola Luizhcota,

    De uma olhada em Keep user credentials secure (http://msdn.microsoft.com/en-us/library/gg584036.aspx). Ao criar a chave DisableSecureDecryptionKey no registry, a opcao deve ser habilitada. No entanto, note que com isso o email router utilizara HTTP ao inves de HTTPS. Veja se isso pode causar algum tipo de implicacao para vc.

    Abracos, Daniel.

    sexta-feira, 27 de abril de 2012 02:36
  • Daniel,

    Obrigado pela dica. Criei a chave DisableSecureDecryptionKey e a opção apareceu. Porém ao tentar fazer o teste, deu outro problema, resolvi colocando o usuário da conta que executa o gerenciador no grupo PrivUserGroup, depois disso o erro mudou mais uma vez. Agora o erro é:

    Nome: Administrador CRM
    Status de Entrada: Falha - Uma tentativa de conexão falhou porque o componente conectado não respondeucorretamente após um período de tempo ou a conexão estabelecida falhouporque o host conectado não respondeu 


    Servidor: smtp.gmail.com
    Status de Saída: Com Êxito


    Luiz Henroqie

    sexta-feira, 27 de abril de 2012 14:18
  • Oi Luiz,

    Apenas de curiosidade, a conta no GMail esta configurada para permitir acesso Pop? (imagino que vc esteja conectando utilizando POP, correto?) Existem outras configuracoes que o Gmail pede que estao em http://support.google.com/mail/bin/answer.py?hl=pt&answer=13287 , elas estao todas de acordo?

    Abracos, Daniel.


    -- Se minha sugestão ajudou, por favor marque-a como útil; Se resolveu a questão, por favor marque-a como resposta. Contribua para melhorar o fórum! | daniel@dimamura.com.br

    segunda-feira, 30 de abril de 2012 15:08
  • Olá,

    Sim está configurada para permitir acesso pop. As configurações estão todas de acordo.


    Luiz Henroqie

    terça-feira, 1 de maio de 2012 22:25
  • Oi Luiz,

    Qual o tipo de autenticacao POP que está sendo utilizada? NTLM? Se for, poderia testar como Clear Text?

    Caso nao funcione, vc poderia enviar o erro que fica no event log do servidor?

    Abracos, Daniel.


    -- Se minha sugestão ajudou, por favor marque-a como útil; Se resolveu a questão, por favor marque-a como resposta. Contribua para melhorar o fórum! | daniel@dimamura.com.br

    quinta-feira, 3 de maio de 2012 00:47
  • Luiz,

    Precisamos que dê seguimento a thread, senão marcaremos uma resposta.

    Att,


    Tiago Michelini Cardoso MVP - MCC - MCTS
    https://tiagomcardoso.wordpress.com/

    segunda-feira, 14 de maio de 2012 12:18
    Moderador
  • Desculpe a demora.  Estou utilizando a Clear Text. Sempre aparecem estes erros:

    Erro ao abrir a caixa de correio usuario@servidor.com.br. System.Net.Sockets.SocketException (0x80004005): Uma tentativa de conexão falhou porque o componente conectado não respondeu

    corretamente após um período de tempo ou a conexão estabelecida falhou
    porque o host conectado não respondeu 
       at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
       at Microsoft.Crm.Tools.Email.Providers.Pop3Client.Connect(Boolean useSsl)
       at Microsoft.Crm.Tools.Email.Providers.Pop3PollingMailboxProvider.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()


    Erro ao abrir a caixa de correio usuario@servidor.com.br. System.Configuration.ConfigurationErrorsException: O parâmetro de configuração "EmailUser" do serviço E-mail Router está ausente. Esse parâmetro é necessário.
       at Microsoft.Crm.Tools.Email.Providers.ConfigNodeReader.GetCheckedStringValue(String elementName, String defaultValue, Boolean throwIfMissing, Boolean hide)
       at Microsoft.Crm.Tools.Email.Providers.ConfigNodeReader.GetCheckedStringValue(String elementName, String defaultValue, Boolean throwIfMissing)
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.Pop3PollingMailboxProvider.OpenMailbox()
       at Microsoft.Crm.Tools.Email.Providers.CrmPollingMailboxProvider.Run()


    Luiz Henroqie

    segunda-feira, 14 de maio de 2012 16:51