none
chamar pagina externa pelo javaScript RRS feed

  • Pergunta

  • galera gostaria de saber apenas como posso chamar uma pagina externa atravez de uma <a href ... ou qualquer coisa do tipo...

    estou tentando algo assim

    <a href=http://www.google.... > LINK <a/>


    mas ta tentando chamar uma tela interna ..

     
    segunda-feira, 16 de novembro de 2009 18:00

Todas as Respostas

  • Ola!


    Caso vc queira abrir em uma outra janela: <a href=http://google.com.br target="_blank"><\a>

    ou na mesma janela <a href=http://google.com.br target="_self"><\a>

    o que define como devera ser aberta é a propriedade target, onde _blank é para abrir em uma nova janela e _self para abir na mesma janela.


    Acho que é isso que vc precisa.



    Israel Gonçalves

    "Ajudou ? Marque como resposta! ^^".
    segunda-feira, 16 de novembro de 2009 19:50
  • israel ,

    eu tambem achava que funcionaria mas na verdade o problema eh outro.. nao me importo se vai abrir na mesma ou em outra tela na verdade o problema eh outro.. oq acontece eh o seguinte quando eu clico no link a URL que se forma no browser eh tipo assim...


    www.EnderecoDomeuServidor.com.brhttp://www.google.com.br entendeu ?

    ele concatena os valores... nao abre simplesmente o site do google .

    fiz um teste local.. criei um link num notepad salvei como html e cliquei.. abre perfeitamente no ambiente de teste mas se eu postar no servidor da esse erro , eu nunca vi isso..

    alguem tem alguma ideia ?

    abraco
    segunda-feira, 16 de novembro de 2009 20:08
  • Bicho ! você não está concatenando isso em algum lugar no código ! 

    o comando está realmente certo !  

    ex: 
       <a href="http://www.yahoo.com.br">Link</a>

    Você não está implementando alguma chamada do lado server ?  

    qualquer coisa posta o código ai ! pra gente ver ! mas esquisito isso ai ! 

    leonardo.diniz
    segunda-feira, 23 de novembro de 2009 15:14
  • Não sei se ja resolveram este caso, mais estava a procura de outra coisa e esbarrei nesta pagina, e observer uma coisa...

    Quando ele mostro la em cima como esta a tag ele não coloco as aspas "no inicio e no fim da url como aqui" sera que não é este o problema, não entendo muito mais observando e comparando com a resposta a cima vi esta diferença nas tag...

    Até mais...
    terça-feira, 5 de janeiro de 2010 03:29
  • boas, isso a mim já me aconteceu quando nao colocava o http://.
    espero ter ajudado.
    segunda-feira, 11 de janeiro de 2010 23:05