locked
Problema com SilverLight em reprodução remota de webstreaming RRS feed

  • Pergunta

  • Prezados,

    Utilizo em meu parque uma estrutura de thin clients / servidor, onde utilizo terminais thin clients com protocolo RDP 1.6 para se conectar ao Terminal Server 2008 R2. Estou com o seguinte problema: ao fazer uma conexão remota RDP do thin client ao servidor, abro o internet explorer e entro em um website onde existem diversas vídeo-aulas em streaming, porém não consigo executá-las. Inicialmente o erro apresentado é este: "Erro Inesperado, Clique aqui, copie o texto apresentado e envie para sua central de suporte."

    Quando clico no local indicado, aparece a seguinte mensagem:

    [23/08/2013 15:16:15] Releasing http://webcast.sambatech.com.br/805640/origin1/account/182/32/2013-05-08/video/2bc5dcf96e1932defcc99e3a632878be/BT070513MAB0105RAL0102L_p1.wmv
    Media Failed: 6013 Erro. Severity: "Warning" Sender: "Player" Type: "MediaFailed" Message: "Media Failed: 6013 Erro." 
    Play State Changed: Opening Severity: "Information" Sender: "Player" Type: "PlayStateChanged" Message: "Play State Changed: Opening" 
    ProgressiveMediaPlugin Loaded Severity: "Information" Sender: "ProgressiveMediaPlugin" Type: "ProgressiveMediaPluginLoaded" Message: "ProgressiveMediaPlugin Loaded" 
    [23/08/2013 15:16:09] aspectRatioWidth: NaN (Não é um número) x aspectRatioHeight: NaN (Não é um número)
    [23/08/2013 15:16:09] pixelWidth: NaN (Não é um número) x pixelHeight: NaN (Não é um número)
    [23/08/2013 15:16:09] Current stretch Mode: Uniform
    Configured Video Size - Height: NaN (Não é um número) Width: NaN (Não é um número) Severity: "Information" Sender: "Player" Type: "ConfiguredVideoSize" Message: "Configured Video Size - Height: NaN (Não é um número) Width: NaN (Não é um número)" 
    Playlist Item Changed Severity: "Information" Sender: "Player" Type: "PlaylistItemChanged" Message: "Playlist Item Changed" 
    Maximum Bitrate Changed: 1500000 Severity: "Information" Sender: "Player" Type: "MaximumPlaybackBitrateChanged" Message: "Maximum Bitrate Changed: 1500000" 
    Playlist Changed Severity: "Information" Sender: "Player" Type: "PlaylistChanged" Message: "Playlist Changed" 
    [23/08/2013 15:16:09] Downloading update for the player.

    Alguém poderia me ajudar? Quando eu executo o streaming através do servidor (localmente) o vídeo executa perfeitamente.

    Recapitulando: estou em um ambiente de Terminal Server, conectando remotamente com um thin client.


    • Editado LuizThinClient sexta-feira, 23 de agosto de 2013 19:17 Correção
    sexta-feira, 23 de agosto de 2013 19:16

Todas as Respostas

  • Amigo,

    Você já verificou se a aplicação está conseguindo chegar até o arquivo?
    Acredito que o problema esteja acontecendo pq ele não consegue carregar o vídeo.



    Não esqueça de marcar como útil uma resposta que te ajude.
    "A diversão é a alma do negócio"

    sexta-feira, 23 de agosto de 2013 19:33
  • Lucas,

    Primeiramente gostaria de agradecer pela ajuda.

    Raras as vezes que o vídeo executa pela conexão remota, na maioria das vezes, 90%, não executa, porém ao abrir o navegador frente a frente com o servidor (localmente), todos os vídeos executam.


    Lembrando que é um endereço publicado na internet, onde posso acessar diretamente da minha casa, e funciona normalmente.

    O aplicativo utilizado é o WAMP SERVER.

    • Editado LuizThinClient sexta-feira, 23 de agosto de 2013 20:22 Adição de Informação
    sexta-feira, 23 de agosto de 2013 20:04
  • Alguém saberia me ajudar? Agradeço desde já.
    segunda-feira, 26 de agosto de 2013 14:41
  • Boa noite Luiz, tive um problema semelhante em outro servidor...

    Gostaria de saber se o seu problema foi resolvido.

    Obrigado pela ajuda, Rafael.

    domingo, 13 de outubro de 2013 02:03
  • Existe uma forte possibilidade de que o problema seja alguma incompatibilidade entre o codec do vídeo e o protocolo RDP ou até mesmo entre o player e o RDP.

    Alguns formatos de vídeo e players interagem de uma forma um pouco mais direta com a placa de vídeo do computador, mas como você está acessando via RDP, a placa de vídeo em questão é virtual, não a física do seu cliente ou do server. Essa placa de vídeo virtual do RDP provavelmente não é compatível com algum comando necessario para de codificar esses vídeos.


    Atenciosamente,

    Kelps Leite de Sousa | MVP Silverlight
    blog: http://kelps.net
    twitter : http://twitter.com/kelps

    Não se esqueça de "marcar como resposta" o ítem que lhe ajudou.

    quarta-feira, 16 de outubro de 2013 10:59