none
Não consigo exibir os dados de um DataSet no ComboBox RRS feed

  • Pergunta

  • Pessoal,

     

    estou tendo muita dificuldade em exibir os dados de um DataSet em um ComboBox.

     

    Ao invês de aparecer o conteúdo do DataSet aparece System.Data.DataRow

     

    Poderiam me ajudar a resolver este problema.

     

     

    Dim sql As String

    Dim da As SqlCeDataAdapter

    Dim ds As DataSet

    sql = "SELECT * FROM forma_cobranca"

    Conn.Open()

    da = New SqlCeDataAdapter(sql, Conn)

    ds = New DataSet()

    da.Fill(ds, "Forma_cobranca")

    cobranca.DataSource = ds.Tables("Forma_cobranca")

    cobranca.DisplayMember = "ds_forma_cobranca"

    cobranca.ValueMember = "cd_forma_cobranca"

    sexta-feira, 18 de maio de 2007 16:22

Respostas

  • Oi !

     

    Verifique 3 coisas :

     

    1) Tente trocar a linha do datasource pelo seguinte :

     

    Code Snippet
    cobranca.DataSource = ds.Tables("Forma_cobranca").defaultView

     

     

    2) Verifique o nome dos campos. Exibir System.Data.DataRow é uma reação normal de uma combo quando não encontra os campos que estão configurados no displaymember e valuemember

     

    3) Experimente atribuir o displayMember e valuemember antes de atribuir o datasource

     

    []'s

     

    sexta-feira, 18 de maio de 2007 17:08

Todas as Respostas

  • Oi !

     

    Verifique 3 coisas :

     

    1) Tente trocar a linha do datasource pelo seguinte :

     

    Code Snippet
    cobranca.DataSource = ds.Tables("Forma_cobranca").defaultView

     

     

    2) Verifique o nome dos campos. Exibir System.Data.DataRow é uma reação normal de uma combo quando não encontra os campos que estão configurados no displaymember e valuemember

     

    3) Experimente atribuir o displayMember e valuemember antes de atribuir o datasource

     

    []'s

     

    sexta-feira, 18 de maio de 2007 17:08
  • Obrigado pela dica  Dennes,

     

    na realidade o que estava acontecendo é que o nome dos campos na tabela esta escrito com letras mairusculas e eu esta colocando no código com letras minusculas.

     

    Não sabia que era case Sensitive.

     

    Alterei e funcionou

     

    Obrigado.

     

     

    sexta-feira, 18 de maio de 2007 17:26