none
Como corrigir o bug de renderização de aplicativos WPF RRS feed

  • Pergunta

  • O bug é esse abaixo. Foi constatado em dois aplicativos, ambos possuem leitura e gravação de arquivos, mas funciona perfeitamente em um outro notebook, mas nesse meu notebook esses dois aplicativos estão com esse problema, é preciso maximizar a tela 2 vezes para que volte ao normal e renderize a aplicação. 



    • Editado Dhimme segunda-feira, 14 de novembro de 2016 06:24
    quinta-feira, 10 de novembro de 2016 18:52

Respostas

  • Bom dia Dhimme,

    Por gentileza, siga os passos sugeridos neste artigo.

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 21 de novembro de 2016 16:02
    Moderador

Todas as Respostas

  • Olá Dhimme,

    Algumas coisas precisam ser analisadas com relação ao ambiente que a aplicação está rodando.

    1 - O sistema operacional é o mesmo para ambos os notebooks?

    2 - As permissões são as mesmas dos dois notebooks?

    3 - Você verificou se a resolução de ambos os notebooks estão iguais? Isso é muito comum em aplicações Windows forms problemas relacionados a layout devido a resolução.

    Procure identificar as diferenças entre eles, como rodou normalmente em um notebook não acredito que seja problema de código da aplicação.

    Veja se consegue mais algumas informações para que a gente possa te ajudar.

    Espero ter ajudado. 



    Klayton Gomes (Software Architecture) MCP/MCTS/MCAD/MCPD/MCSD Solution Developer

    • Sugerido como Resposta AndreAlvesLimaModerator sexta-feira, 11 de novembro de 2016 13:17
    • Não Sugerido como Resposta Dhimme segunda-feira, 14 de novembro de 2016 06:22
    sexta-feira, 11 de novembro de 2016 12:49
  •           Fiz um novo teste. Criei um programa qualquer, uma janela com um listBox, e nesse listBox eu adicionei 60 itens, porq eu desconfiei que o problema era relacionado a controles como: ListBox, ComboBox, TreeView. O bug ocorreu no notebook em que todos os aplicativos WPF que contém algum desse controle mencionado acima estão. E no notebook onde roda perfeitamente qualquer aplicação WPF não há nenhum bug.  Lembrando que o programa roda normalmente em seu estado normal, mas quando maximiza ele, ocorre esse bug. Ou seja, ao executar ele abre normal sem nenhum bug na renderização, mas quando maximiza ele buga.

    Segue abaixo as imagens.

    Programa em seu estado normal no notebook onde ocorre o bug:

    Ocorrência do bug ao maximizar o programa:

    Programa executando em outro notebook estado normal e maximizado:



    Especificação do notebook onde ocorre o problema:

    SO: Windows 10 64Bits atualizado com a ultima atualização.

    Processador Intel i3 1.70GHz

    4GB de Ram, 

    Placa de vídeo: Intel HD Graphics Family 4400 , 2GB

    _____________________________________________________

    Especificação do notebook onde não corre o problema:

    SO: Windows 10 64Bits atualizado com a ultima atualização.

    Processador Intel Core 2 Duo 1.50GHz

    2GB de Ram, 

    Placa de vídeo: Intel HD Graphics  , 1G


     Ambos os notebooks estão com drives atualizados.
    • Editado Dhimme segunda-feira, 14 de novembro de 2016 06:23
    sexta-feira, 11 de novembro de 2016 23:20
  • Bom dia Dhimme,

    Você tem a versão mais recente do .NET instalado em ambas as máquinas?

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 16 de novembro de 2016 13:08
    Moderador
  • Sim, ambos os notebooks possuem .NET 4.5 e 4.6

    Há algum tipo de componente que os controles ListBox, TreeView, ComboBox usem para ocorrer esse problema? Parece algo haver com o carregamento. Até um programinha instalado com o instalador próprio do VS ocorre esse problema.

    segunda-feira, 21 de novembro de 2016 04:11
  • Bom dia Dhimme,

    Por gentileza, siga os passos sugeridos neste artigo.

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 21 de novembro de 2016 16:02
    Moderador
  • Bom dia,

    Devido a falta de interação do autor dessa pergunta,

    essa thread está sendo fechada. Caso o problema ainda

    esteja ocorrendo, favor abrir uma nova thread.

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 24 de novembro de 2016 11:26
    Moderador