none
SQLCE + WinCE 4.2 + Intel PXA270 RRS feed

  • Pergunta

  • Olá.

    Desenvolvi uma aplicação para um dispositivo com WinCE 4.2, processador ARM e banco de dados SQLCE3.0.

    A aplicação funciona perfeitamente, mas agora preciso migrá-la para outro dispositivo, também WinCE 4.2, mas com processador Intel.

    O problema é que eu não consigo encontrar a versão do SQLCE para processador Intel (quando o SO é WinCE 4.2), a versão que é distribuída com o SQL Server 2005 Mobile Edition é somente para processador ARM (sqlce30.ppc.wce4.armv4.CAB).

    Existe algum patch, ou alguma versão que resolva o meu problema ?

    Obrigado.

    segunda-feira, 16 de abril de 2007 20:19

Respostas

  • Olá Ana Paula.

     

    Você já tentou instalar a versão p/ Armv4i (sqlce30.wce5.armv4i.CAB) que vem com o SQL CE 3.0 ?

    Se não der certo tente a versão p/ WinCE 4.2 (sqlce30.ppc.wce4.armv4.CAB).

     

    Eu não me lembro exatamente qual versão a gente utilizou, mas acho que foi uma destas duas.

     

    P/ MC3000 com WinCE 4.2 e processador Intel a gente ainda não conseguiu fazer o SQL CE funcionar.

     

    Espero que tenha lhe ajudado.

    quarta-feira, 25 de julho de 2007 17:07

Todas as Respostas

  • Tem certeza? Pela página do SQL Compact (http://www.microsoft.com/sql/editions/compact/sysreqs.mspx)  não fala de nenhuma restrição ao ARM...

    Só por curiosidade, qual device/processador está usando?

    sexta-feira, 20 de abril de 2007 16:58
    Moderador
  • Mas o processador não é ARM, é um Intel PXA270.

    Para o Windows CE 5.0 tudo bem, mas o problema é o Windows CE 4.2.

    O dispositivo é um Symbol MC3000.

    quinta-feira, 26 de abril de 2007 20:40
  • Olá rafael,

     

    Estou tentando desenvolver uma aplicação para um MC3000 também, mas a versão do Windows é 5.0, não estou sabendo usar a versão do sqlce correta, o processador é Intel PXA270, como saber qual o arquivo correto para instalar?

     

    Obrigada.

    quarta-feira, 25 de julho de 2007 12:30
  • Olá Ana Paula.

     

    Você já tentou instalar a versão p/ Armv4i (sqlce30.wce5.armv4i.CAB) que vem com o SQL CE 3.0 ?

    Se não der certo tente a versão p/ WinCE 4.2 (sqlce30.ppc.wce4.armv4.CAB).

     

    Eu não me lembro exatamente qual versão a gente utilizou, mas acho que foi uma destas duas.

     

    P/ MC3000 com WinCE 4.2 e processador Intel a gente ainda não conseguiu fazer o SQL CE funcionar.

     

    Espero que tenha lhe ajudado.

    quarta-feira, 25 de julho de 2007 17:07