none
Crystal Report runtime está travando RRS feed

  • Pergunta

  • Olá estou tentando corrigir um erro em minha aplicação, utilizei o FUSLOGVW.exe para saber quais erram as dlls que estavam faltando. Ele está me devolvendo essa msg: Mas a dll msvcm80.dll mão faz parte do meu projeto, como posso fazer para inclui-la? Veja a msg erro erro:

    ***** Entrada de Log do Fichário de Assembly (30/06/2015 @ 08:12:41) ***

    A operação falhou. Resultado da associação: hr = 0x80131040. Nenhuma descrição disponível.

    Gerenciador de assemblies carregado de: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll Executando sob executável C:\Sistema\SisEco.exe --- Segue um log detalhado de erros.

    === Informações sobre estado pré-associação === LOG: DisplayName = msvcm80, Version=8.0.50727.4940, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a (Fully-specified) LOG: Appbase = file:///C:/Sistema/ LOG: PrivatePath inicial = NULL LOG: Dynamic Base = NULL LOG: Cache Base = NULL LOG: AppName = SisEco.exe

    Chamando assembly: (Unknown).

    LOG: esta associação começa no contexto de carregamento default. LOG: usando arquivo de configuração de aplicativo: C:\Sistema\SisEco.exe.Config LOG: usando arquivo de configuração de host: LOG: usando arquivo de configuração da máquina de C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config. LOG: referência pós-política: msvcm80, Version=8.0.50727.4940, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a LOG: a pesquisa de GAC não foi bem-sucedida. LOG: tentando download de nova URL file:///C:/Sistema/msvcm80.DLL. LOG: o download do assembly foi bem-sucedido. Tentando configuração do arquivo: C:\Sistema\msvcm80.dll LOG: entrando na fase de configuração executada a partir da origem. LOG: o nome do assembly é: msvcm80, Version=8.0.50727.4927, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a AVI: a comparação de nome de assembly resultou na incompatibilidade: Revision Number ERR: a referência do assembly não correspondeu à definição de assembly localizada. ERR: falha na fase de configuração executada a partir da origem com hr = 0x80131040. ERR: falha ao concluir configuração do assembly (hr = 0x80131040). Probing encerrado.

    * Entrada de Log do Fichário de Assembly (30/06/2015 @ 08:12:41) *

    A operação falhou. Resultado da associação: hr = 0x80131040. Nenhuma descrição disponível.

    Gerenciador de assemblies carregado de: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll Executando sob executável C:\Sistema\SisEco.exe --- Segue um log detalhado de erros.

    === Informações sobre estado pré-associação === LOG: DisplayName = msvcm80, Version=8.0.50727.4940, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a (Fully-specified) LOG: Appbase = file:///C:/Sistema/ LOG: PrivatePath inicial = NULL LOG: Dynamic Base = NULL LOG: Cache Base = NULL LOG: AppName = SisEco.exe

    Chamando assembly: (Unknown).

    LOG: esta associação começa no contexto de carregamento default. LOG: usando arquivo de configuração de aplicativo: C:\Sistema\SisEco.exe.Config LOG: usando arquivo de configuração de host: LOG: usando arquivo de configuração da máquina de C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config. LOG: referência pós-política: msvcm80, Version=8.0.50727.4940, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a LOG: a pesquisa de GAC não foi bem-sucedida. LOG: tentando download de nova URL file:///C:/Sistema/msvcm80.DLL. LOG: o download do assembly foi bem-sucedido. Tentando configuração do arquivo: C:\Sistema\msvcm80.dll LOG: entrando na fase de configuração executada a partir da origem. LOG: o nome do assembly é: msvcm80, Version=8.0.50727.4927, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a AVI: a comparação de nome de assembly resultou na incompatibilidade: Revision Number ERR: a referência do assembly não correspondeu à definição de assembly localizada. ERR: falha na fase de configuração executada a partir da origem com hr = 0x80131040. ERR: falha ao concluir configuração do assembly (hr = 0x80131040). Probing encerrado**

    terça-feira, 30 de junho de 2015 12:55

Respostas

  • Depois de quebra a cabeça e quase ficar louco,
    descobri o que ocasionou o erro.

    A fonte de dados do ODBC estava configurada só para "Fonte de dados de usuário".

    Foi só eu trocar para a "Fonte de dados de sistema" que esta tudo funcionando perfeitamente. 
    quarta-feira, 1 de julho de 2015 20:06