none
Erro no Web user Control RRS feed

  • Pergunta

  • Boa tarde!

    Eu criei um web user control para mostrar o meu Menu....

    ex:

    <%@ Control Language="C#" AutoEventWireup="true" CodeBehind="Menu.ascx.cs" Inherits="SMC.WebUserControl1" %>
    <div style="width: 1150px; height: 18px;">
        <div style="height: 16px; float: left;">
            <asp:Menu ID="MenuGeral" runat="server" Font-Size="12px" Font-Names="Arial,Geneva,Helvetica, sans-serif"
                Orientation="Horizontal">
                <DynamicMenuItemStyle HorizontalPadding="3px" VerticalPadding="3px" />
            </asp:Menu>
        </div>
    </div>

    _____________________

    e em cada página eu chamo aquele menu....

    <%@ Page Title="Home Page" Language="C#" MasterPageFile="~/Site.Master" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="SMC.Default" %>

    <%@ Register src="Menu.ascx" tagname="Menu" tagprefix="uc1" %>

     <uc1:Menu ID="Menu1" runat="server" />

    ___________________

    Executando local funciona perfeitamente, porém quando eu jogo para o servidor o menu não funciona!!!

    ele não mostra os nódulos filhos e perder o link para a página!

    ______________

    Alguém sabe o que é?

    quarta-feira, 18 de março de 2015 19:33

Respostas

  • Dá algum erro?

    • Se der algum erro pode significar a ausência do arquivo Menu.ascx no servidor.
    • Talvez seu arquivo de estilização (.css) não está sendo carregado e você não vê o menu, mas ele está lá.
    • Verifique se há dados no servidor para que o menu seja populado e consecutivamente apareça
    • Verifique se todos os arquivos foram publicados

    Provavelmente não há dados no banco de dados do servidor iguais ao do seu ambiente de desenvolivmento e por isso ele não parece.


    • Marcado como Resposta Marcos SJ quarta-feira, 10 de fevereiro de 2016 19:20
    quarta-feira, 10 de fevereiro de 2016 19:13

Todas as Respostas

  • Por exemplo: Local aparece assim o menu....

             no servidor não aparece

    quarta-feira, 18 de março de 2015 19:53
  • Boa tarde MBarthman,

    Tudo bem?

    Encontrou alguma solução para o seu problema?

    Atenciosamente


    Marcos SJ

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 10 de fevereiro de 2016 18:54
  • Dá algum erro?

    • Se der algum erro pode significar a ausência do arquivo Menu.ascx no servidor.
    • Talvez seu arquivo de estilização (.css) não está sendo carregado e você não vê o menu, mas ele está lá.
    • Verifique se há dados no servidor para que o menu seja populado e consecutivamente apareça
    • Verifique se todos os arquivos foram publicados

    Provavelmente não há dados no banco de dados do servidor iguais ao do seu ambiente de desenvolivmento e por isso ele não parece.


    • Marcado como Resposta Marcos SJ quarta-feira, 10 de fevereiro de 2016 19:20
    quarta-feira, 10 de fevereiro de 2016 19:13